No wi-fi calling on t-mobile since installing spitz AX GL-X3000

Hi, I am a complete newbie and we have been struggling to get connectivity at our new and very remote lakehouse. I was so excited to get the GL-X3000 after learning about it from my nephew. The good news is that the internet is working and all of my devices are connected and working. The VERY bad news is that I can no longer receive or make phone calls on my iphone 12 or my husband’s iPhone XR via wi-fi calling. We were able to make calls on the Spitz GL X750C4 which the GL-X3000 replaced. Our cell service is almost non-existent here and so we rely on wi-fi calling for all of our calls. Can anyone please suggest what I might have set up incorrectly or a setting that should be changed for us to begin to make and receive calls again?

Do you have VPN enabled?

Others have described similar issues where some VPNs cause it to be unavailable. The exact cause is still being investigated.

Yes, i have vpn enabled and its a must for me to enable it. Appreciate if i can get an update about the investigation please thanks in advance :smiling_face:

I do not have VPN enabled but still no Wi-Fi calling. My children are arriving tomorrow for the week and not only do I need to be able to make calls, but they will as well. I’m feeling rather desperate about it and would appreciate some help.

I will test WiFi calling on Monday when I can access my x3000.

After downloading the Jool-tools and 464XLAT plugins, I noticed that my Wifi-Calling feature started working effectively. Previously, when I didn’t have these plugins installed, the feature was not functioning properly, and my device was assigned the IP address 192.0.0.1. Also set IPv6 to Passthrough!

It is worth mentioning that I have also enabled a WireGuard VPN but limited it to specific MAC addresses.

By incorporating the Jtools and 464XLAT plugins into my setup, my device now receives proper IPv4 and IPv6 addresses from T-Mobile, allowing Wifi-Calling to function seamlessly.

1 Like

Thank you so much!!! I am excited to see if this will work for me. I’m a complete newbie so I’m not sure how to add Jtools and 464XLAT plugins or WireGuard VPN, but I’m going to try to figure it out. Thank you again!

You’re welcome! I’m glad I could assist you.

To add Jool-tools and 464XLAT plugins, follow these steps:

  1. Access your router’s settings by entering “192.168.8.1” in your web browser’s address bar.
  2. Navigate to the “Applications” section and locate the plugins for Jool-tools and 464XLAT. Download them from the available options.
  3. Next, go to the “Network” section and select “IPv6.” Enable IPv6 and choose the “Passthrough” option.
  4. Reboot your router to apply the changes. After the reboot, your router should display the assigned IPv6 address and a CGNAT IPv4 address provided by T-Mobile.
  5. To test the functionality of Wi-Fi calling, enable airplane mode on your phone while keeping Wi-Fi turned on. You should see the T-Mobile Wi-Fi calling feature appear.

Regarding the stability of 464XLAT, it seems to have intermittent issues and may not work consistently after every reboot. It would be beneficial if the underlying cause of this issue could be further investigated and resolved. Additionally, please note that it appears to function properly on 5G-NSA (Non-Standalone) networks but requires more testing on 5G-SA (Standalone) networks.

Edit to add:

Sun Jul  2 23:10:44 2023 daemon.notice netifd: Interface 'modem_0001_6_4' is now down
Sun Jul  2 23:10:44 2023 daemon.notice netifd: Interface 'modem_0001_6_4' is setting up now
Sun Jul  2 23:10:44 2023 daemon.err odhcpd[4368]: setsockopt(PACKET_ADD_MEMBERSHIP): Invalid argument
Sun Jul  2 23:10:57 2023 daemon.notice netifd: Interface 'modem_0001_6_4' is now down
Sun Jul  2 23:10:57 2023 daemon.notice netifd: Interface 'modem_0001_6_4' is setting up now
Sun Jul  2 23:10:57 2023 daemon.err odhcpd[4368]: setsockopt(PACKET_ADD_MEMBERSHIP): Invalid argument
1 Like

wisty_bakery_0y I was able to download the Jool-tools and 464XLAT applications. I enabled iPv6 and chose Passthrough and then rebooted. I did not know where to go to to check that there was an assigned iPv6 address or a CGNAT iPv4 address but after reboot the iPv6 setting was mantained. Unfortunately not only could I still not make a phone call after completing the process and turning Airplane mode off and on again on my phone, I also completely lost my internet connection. Clearly I have done something wrong. :frowning: Any additional advice would be much appreciated. I should also mention that the network that always is shown is 5G-SA and so, based on what you said, that could be the issue? Is there some way to change that to 5G-NSA? Thanks again for all of your help with this!!

On the main page of your router, navigate to the “Internet” tab, where you should see the type of connection listed as T-Mobile. Look for the “IP Address” and “IP Address IPv6” fields. Below, you’ll find a button labeled “Manual Setup.” Click on it and enable Band Masking. Set the masking mode to “Open” and select all LTE and 5G NSA bands while ensuring that no 5G SA bands are selected. Apply the changes, and the router will restart with the new settings.

To get Jool-Tools working, follow these steps:

  1. Go to “System” and select “Advanced Settings.”
  2. Enter “root” as the username and your password to access the Luci Admin Panel.
  3. In the Luci Admin Panel, navigate to the “System” menu and choose “Startup.”
  4. Click on the “Local Startup” tab and add the following command above “exit 0”: ‘jool instance add --pool6 64:ff9b::/96’.
  5. Logout from the Luci Admin Panel and reboot your device.

After the reboot, you should be connected to T-Mobile 5G-NSA and have both a proper IPv4 and IPv6 address.

Regarding the 5G-SA network, it seems to only work with IPv6, which may cause the issue you’re experiencing. It would be helpful if the Gl.iNet staff looked into this. They might consider adding a PDP setting to the Manual Setup to force IPv4, IPv4/iPv6, and IPv6 configurations, which could potentially resolve the problem. Additionally, including 464XLAT in the IPv6 Settings Page instead of just passthrough could be beneficial.

> Main Page of Router

> APN Custom Settings

Thank you so much for all of your suggestions. I couldn’t tell you exactly what worked because I kept tweaking everything and following all of the advice given but the good news is we finally have phone service again and our Internet is the best it’s ever been here. What a relief! Thank you so much for all your help!

1 Like

I know you may not want to touch your setup which works well.

But if there is a chance I hope you can find out exactly what can be done to make wifi calling work for T-Mobile

I also have tmobile on x3000 5g and have no problems with wifi calling. Has worked well since installed.

I literally followed every suggestion I was given. Thankfully nothing cancelled the other out and everything worked together. And getting this figured out was a God send. My sister passed away two days ago and I got everything working just in time to receive the call and to speak with my family. Since I’m 3 hours away being able to speak with my family was very important so thank you all again so much. I appreciate your help more than you can know.

I understand the importance and I’m more than willing to help so someone else can use the information. If you can give me a week to get past my sister’s funeral, I will run through it and try to figure it out. We don’t have her funeral arrangements made yet and I will be traveling to the funeral, so I can help any time beginning the week of the 17th.

3 Likes

I’m sorry for your loss, and I’m glad everything worked out for you during that difficult time.

I wanted to share an update regarding my efforts to enable wifi-calling on the 5G SA network. After some extensive tinkering, I’ve managed to find a workaround that is working for now. Let me explain the steps I took:

  1. First, I adjusted my APN Configuration to Band Lock, ensuring that only 5G SA is used. This preference for a pure 5G network with 5G Core, rather than 5G NSA which utilizes 4G LTE, was important to me, even though 5G NSA assigns proper private IP4 addresses.

  2. Additionally, I set the IP6 configuration to NAT6, which allowed me to obtain public IP6 addresses on all my devices and IP4 addresses using T-Mobile’s CGNAT and 464XLAT CLAT.

  3. One of the challenges I encountered was that users on the 5G SA network were all assigned the same IP address (192.0.0.2) and gateway (192.0.0.1). Despite being able to ping the wifi calling servers, my iPhone still refused to connect.

  4. To address this issue, I set up WireGuard with custom rules enabled. I specifically configured the following IP ranges with a metric of 0 and a scope set to link: 208.54.0.0/16, 66.94.0.0/19, and 206.29.177.36/32. This configuration ensures that only these IP blocks traverse the VPN.

  5. Since implementing these changes, all my traffic has been successfully traversing T-Mobile’s IP4 and IP6 network without any issues. Interestingly, using NAT6 and 5G SA has even allowed me to use my Xbox and multiplayer games without the need for a VPN.

  6. I also confirmed with ipleak.net that all T-Mobile addresses and DNS servers are reachable. As a result, I can now make and receive texts and calls on wifi-calling even when my phone is in airplane mode.

While this workaround has proven effective, I believe there is still room for improvement. It may be worth exploring options such as proper configuration of 464XLAT on the router or potentially utilizing NAT hole punching to achieve a more streamlined wifi-calling SIP setup without the need for a VPN and custom rules.

After implementing these modifications, I have achieved download speeds of 485mbps or higher and upload speeds of 85mbps or higher, with a low ping of 9. In comparison, the 5G NSA network provided download speeds of around 350mbps or higher, upload speeds of 35mbps or higher, but with a higher ping of 62. These results highlight the improved performance and responsiveness of the 5G SA network with the implemented changes.

2 Likes

Thank you for sharing. Just wanted to ask how you set up the wireguard custom rules. I tried to set it up on the VPN section of the router page but didn’t know how to add these IP addresses.

Can you clarify your method for setting up wireguard (step #4)? Preferably a screen shot of how you set it up.

The quickest solution I found is to block all SA bands and only allow NSA and LTE bands and reboot router.