Wifi calling issue with AX1800

i have mudi E750 with version 4.3.2 snapshot in which wifi calling is working but on AX1800 i have version 4.2.1 release where wifi calling isn’t working.

Do you have VPN enabled when you call?

1 Like

Yes and i need that.

Vpn is enabled on the GL.iNet router not on device.

@yuxin.zou, wificalling isn’t getting enabled at all when i connect to AX1800 Flint router.

it shows like this on the mobile device if wificalling is enabled. but in my case its not showing.

Check if any of the ports listed below is blocked or not allowed for typical Wi-Fi calling(IPsec VPN to carrier):

  1. UDP port 500
  2. UDP port 4500

I dont see any blocking on the router

I don’t know but specifying MTU more than 1500 fixes my issue.


can anyone please explain me if this an optimal solution, bcoz what i know is more than 1500 will do fragmentation of IP packet.

1 Like

@yuxin.zou i have collected pcaps to investigate the issue, if you dont mind can you please look into this. what i have absorbed restarting the phone when connecting to GL.inet router fixes the issue. its like whenever i have issue i just restart the phone, but this is not the case when connected to other wifi.

@yuxin.zou pcaps share to you in direct message.

Thanks, we will check it.

1 Like

We checked the pcaps. Which did not have any packets longer than 1500. It doesn’t seem to have anything to do with MTU.
It breaks every time in the AUTH process. Maybe this has something to do with the exit IP address?

True doesnt look like an MTU issue, but i dont think its ip address either bcoz.

I have a router in home country running openvpn server to which my other router in different country connects as a client. And on my visit to my home country i never face this issue but when connected over the openvpn i face this issue. I tried different router as well but never seen this issue.

I tried different router like linksys wrt3200acm its works fine without any issue.


It seems to be VPN related, which VPN server do you have? Have you tried a different provider’s configuration or used WireGuard?

I have tplink archer ax6000 router running openvpn server and gl.inet is connecting as a client to it.

I tried different vpn provider and it works fine.

I bought another ax1800 flint router for running wireguard server as the one i have from tplink doesnt support wireguard. Im planning to replace it with flint, the only thing im afraid of is ax supports more than 6gbps throughput but flint supports only 1800.

@yuxin.zou Can you please advice on this.


@yuxin.zou i’m facing same behaviour when i connect both AX1800 as s2s.

Our 6Gbps-enabled desktop routers are scheduled to come in Q4. Or a little earlier.

We will check this issue.

@yuxin.zou is there any update on this, thanks.

We ran some tests, but the situation is complicated and it seems to be mobile network operator and VPN server address related.
Some operator restrict Wi-Fi Calling to IPs in other areas……

I think its something to do with dns as per my understanding, bcoz when you connect to different wifi what happens is the dns get changed and then u start facing the issue bcoz it resolves to the ip which doesnt allow the source ip we are coming from. Until u restart and get connected to vpn wifi to resolve the corrct ip which is allowing the souce ip we are coming from.

I dont have a rooted android phone to edit the host files to force the dns, if you have can you do a test and let me know if it fixes the solution.