One thread to rule them all: GL AR750S (Ext) Slate - Firmware Update Problems

Hey there, I’ve just had a heck of a time trying to debrick a GL-AR750S-Ext (Slate) router, and thought I would collect my observations in one place because I had to search through like 15 threads on this forum to figure it out.

I do finally have a working Slate with the latest 3.212 firmware, but I had to try, try again, give up, and try again some more before arriving there.

If you are experiencing the following problems updating Slate firmware:

  • In UBoot update, update hangs with “UPDATE IN PR” displayed in the browser
  • In UBoot update, you get “UPDATE FAILED”
  • In UBoot update, update appears to proceed, but firmware does not appear to be flashed and device never restarts
  • In Local Update from GL firmware, you get verification failed

Here are the steps that worked for me

Note: if you plug the Slate into a network using 192.168.8.x (which can happen if your existing LAN also uses a GL-inet router), you will need to change Slate’s “LAN IP.” The Slate’s firmware will warn you about this if you click the Internet tab. I recommend setting this value to 192.168.7.1 if you have this issue.

  1. In U-Boot, flash the 3.104 firmware (.img file)
  2. If flash is successful, log into the router / set up admin password etc
  3. In GL-inet firmware “Local Upgrade”, flash the 3.105 firmware (.tar file), and turn off "Keep Settings"
  4. If flash is successful, log into the router / set up admin password etc
  5. In GL-inet firmware “Online Upgrade”, flash the latest firmware available, and turn off "Keep Settings"

This strange & unusual upgrade path is due to a combination of limitations in the GL-AR750S, UBoot bugs, and so forth.

Reference:

If you need to use UART to flash

I haven’t had to do this, so I haven’t yet documented the procedure, but please feel free to post here and if possible I’ll add the info to this post/thread.

3 Likes

Maybe your uboot is old.

Have you tried upgrade uboot itself. In uboot failsafe, access 192.168.1.1/uboot.html and flash this one

Then uboot failsafe mode should work for latest firmware