Only 1MB/s between devices. GL-MT300N-v2


I am struggling with two problems since a while now and can’t find out why:

1. When i copy data from one device to another. In this case from WindowsPC to another WindowsPC. Both connected to the GL-Mt300 wifi with strong signal. The transfer rate is only 1MB/s or less. That’s way too slow. :thinking:

All have the same distance to the router. And i also tried other PCs.

What can cause that? And how do i find out the reason behind it?

2. Different internet speeds for different devices.
I use the MT300 as a repeater and with my Windows PC i get 19 Mbps internet speed. On my phone i get only 2 Mbps!?
When i connect my phone to the AP which is connected directly to the internet. Then i also get 19Mbps on the phone. Why does my phone get only 2Mbps via the GLinet router?

Another thing: If two devices or more using internet my ping rates get really slow:
It should be around 25ms. Normal or not?

I don’t think that is normal behavior. On the website this router is advertised with 300Mbps. So what am i doing wrong here? :slight_smile:

Thanks for any solutions, tips or hints.


And that’s how it looks like when i ping the MT300:

So the bad ping times do not come from the internet. It’s a router issue happening inside the LAN. That can’t be normal. In which direction should i investigate?

After some more testing it turns out that latency works well (4ms ping times to router) when my IoT devices are not connected. So instead of 17 devices. There are now only 2 devices connected and the ping times look pretty good.

The transfer rate within the LAN is still under 30Mbps. That’s only 10% of the advertised speed. Still not sure why that is happening.

WiFi is 300Mpbs in specs but in reality max wifi speed will be 70-80 max in 2.4G. On WiFi, 30Mbps is not bad. If you need faster, you may need to use a dual-band router.

Seems your IoT device are making trouble?

wifi speed will be 70-80 max in 2.4G

Okay. That clarifies my “low” LAN bandwidth. Thanks

Seems your IoT device are making trouble?

Wasn’t home the last days. But i will do more tests soon to find out how my IoT devices create trouble and report here again.
I am using MQTT with Domoticz and NodeRed.
Sensor/Actuator software: ESPeasy

It seems that it is not my IoT devices. Even after a fresh reset of the GLinet router and only one device connected i still get time outs and ping times of >100ms to the router.

I think it’s better to discuss that in a new thread:

FWIW - should not have split the threads, IMHO…