Open vpn的配置调试问题希望得到帮助

我的设备是MIFI
需求是通过OPEN VPN访问 4G路由器的LAN口区域
目前使用TAP模式建立vpn时报错
报错信息为
WARNING: this configuration may cache passwords in memory – use the auth-nocache option to prevent this
[R7000] Peer Connection Initiated with [AF_INET]X.X.X.X:1194
TUN/TAP device tap0 opened
/etc/openvpn/update-resolv-conf tap0 1500 1587 init
ERROR: Linux route add command failed: external program exited with error status: 1

根据我在论坛查找资料显示存在完全同样的问题

并且存在解决方案

但是我对linux命令不熟悉对第一步操作,希望有大佬能够给出点详细的说明如何操作,当然ssh到设备我还是会的

第二部的关闭DHCP 如果关闭DHCP那么如何正常的访问互联网呢只通过server端访问吗
希望能得到帮助

对于国内客户,我们不对这方面做支持。有特殊用途可以自己研究

我只是家庭网与MIFI进行vpn互联主要是为了实现内网穿透 相关类型的ipsec vpn设备 ssl vpn设备 各种一线品牌的防火墙路由器中都是很常见的功能,贵公司有点过于上纲上线了 大部分tp设备也支持ipsec vpn L2TP并未有任何法律上的问题

并未需要访问国外网站,只是为了家庭网络与mifi的互联,麻烦支持一下 我认为这并未与任何规定相违背

而且对我的工作有巨大的影响希望能够给一些建议

这个错误并不会影响TAP0的生成,因此你可以忽略
你找的这个链接,应用场景是需要将VPN接口桥接,你如果仅仅想访问路由器lan口,可以在luci上配置vpn->lan的转发
你也可以将tap0和LAN口直接桥接在一起,可以直接在luci操作

这个错误并不能使我的open会话建立起来,之前使用tun模式时是可以正常建立的,但是server端(R7000梅林)总是把去往MIFI的LAN口流量转发到互联网,这又是一个大难题,所以我选择改用TAP模式,如果我忽略这个报错 会话并不能正常建立,一直在重复的尝试建立,服务端也未显示该客户端在线
最终提示结果如图

你的配置文件中有错误,可以共享你的配置文件吗?

你是想家里内网跟MiFi互连?
如果你家里有public ip ,那很简单。参考 https://docs.gl-inet.com/en/3/app/cloud/#site-to-site_1
网上有其它网友分享怎么找运营商要public ip,动态的public ip也行。

client1.zip (1.2 KB)
附件是我的配置文件
截图是server端配置


感谢!

已经申请了公网地址

访问家里的内网在tun模式下已经实现,需要访问mifi的lan口区域

这个site2site确实是我想要的功能效果

但是只有一台GL-iNet设备 家里内网是网件的R7000 梅林固件

你是想实现site2site的功能,openvpn应该是不行的
有人这么做过,结果是行不通的, Openvpn site-to-site

确实, site to site 需要两台 gl.inet 路由器。
要不再买一台得了。

嗯,我也看过这个帖子需求类似,我还是想把桥模式做起来再调试一下看看能不能打通,我认为可行性非常之高,这边还是麻烦帮忙修改一下openvpn的配置,如果对接成功了以后仍然不行,那我就只能放弃openvpn协议了

另外,请问就目前的情况来看 想从互联网 访问4G路由器的LAN口区域 还有什么别的办法没有 这个问题真的是令人绝望,我已经研究了很久 心碎

这个设备是用于我出差调试使用,希望是通过笔记本或者其他终端从互联网无缝的接入MIFI的lan口区域对LAN口下的其他设备进行调试,如果4G能有公网地址 做映射,那么一切都没有问题,可惜它没有

只是远程访问,没必要这么复杂吧!
开个端口转发啥的不行吗?

QQ%E6%8B%BC%E9%9F%B3%E6%88%AA%E5%9B%BE20190925104945
这是个令人心塞的话题,电信4G只分配私网地址

画一下你的拓扑图,看下有没有简单的解决方案

%E6%97%A0%E6%A0%87%E9%A2%98
拓扑
4G路由器前段存在电信端NAT 这个没办法改变,投诉过电信很多次,并不能解决

确实没有更好的办法,我先试下你的ovpn配置。
你的R7000支持wireguard吗?wireguard对于这种拓扑结构很好解决

查找了一圈 暂时没有能支持wireguard的固件,可能我需要考虑更换设备了,暂时还是麻烦您帮忙修改一下OPEN配置,我再做尝试