OPKG update failed - MT2500

just got a MT2500 and was starting to configure things up by installing softwares.
I ran into a couple of issues with DDNS.
First one is that no-ip is not in the list despite the fact that I installed ddns-scripts-noip, can’t figure out why.
The other one is linked to DuckDNS, in order to have the service runnning properly, I need to install wget-nossl, installation works and duckddns works afterward but after updating opkg I get the following message:

Collected errors:
 * opkg_download: Failed to download https://fw.gl-inet.com/releases/v21.02.3/kmod-4.0/aarch64_cortex-a53/mediatek/mt2500/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://fw.gl-inet.com/releases/v21.02.3/packages-4.0/aarch64_cortex-a53/glinet/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://fw.gl-inet.com/releases/v21.02.3/packages-4.0/aarch64_cortex-a53/packages/Packages.gz, wget returned 1.```

Any idea why?

Thank you!

I think wget-nossl broke the opkg update, see the post below.

No-IP is broken even in the latest 4.2 firmware for the brume 2. You can get it working by configuring a custom ddns provider that uses the special no-ip script, but there are multiple things that need to be corrected in various places to get it working. I’m not sure if all of these steps are needed, but it seems to be working none the less.

  1. Enable ddns in the brume UI (if you don’t, DDNS in the luci interface seems not to autostart despite my best efforts).
  2. Install the plugins from the Luci software list needed to enable the ddns addon in luci and the no-ip support script (ddns-scripts_no-ip_com, luci-app-ddns, luci-i18n-ddns-)
  3. You should now see the brume UI ddns providers in the Luci ddns UI list. Add a third provider using the “Custom” service type. Fill in the information you know, user and pass should NOT be URL encoded despite the field note (the no-ip script handles this I think). Provide the full file path to the custom noip script installed at the start, it should be something like /usr/lib/ddns/update_no-ip_com.sh
  4. Using ssh now you need to edit some files on the brume. In /etc/config/ddns you need to go the section for the custom provider you setup and remove the service name option, its value will be a dash “-” (remove the entire row including “option”). Then edit the custom no-ip script, the update URL’s in the script have noip.com as the website, but noip’s documentation specifies the URL as no-ip.com, so add the dash “-” to the middle of each URL.
  5. Restart the ddns service in the luci UI and it should work (at least it did for me). I haven’t had time to test if any of these steps are unnecessary so maybe you don’t need them all, I don’t know.

To follow up on my previous response, apparently the no-ip issues are fixed in openWRT version 22, but the brume firmware is ages behind on some 21 version. Dont know when or if they will update their image.

Thanks, yes seems like it’s broken, installing only the package wget-ssl worked out and opkg update fine.

Thank you @thinredline87, somehow after installing ddns-scripts-noip I can see the no-ip in the ddns provider list, but toward the bottom of it, not in alphabetical order.
Still cannot get it to update though when I use it, I need to investigate and try to follow your instruction to see if it works better with a “Custom” service