Please confirm t-mobile setting for Spitz AX 3000

I have no problem with Visible or AT&T on this router, but I cannot get t-mobile to work. I’ve also tried IPv6 (all modes). I’ve tried limiting to LTE bands. While I don’t have t-mobile home internet, I’m glad to try settings for it as well. Please let me know some known, good configurations including APN, TTL/HL, MTU, IPv4 or IPv6, etc. I’m open to all suggestions. Thanks.

Follow these directions to enable wifi calling:

TTL: 65
HL: 65
MTU: leave blank (Optional)

That’s it. BUT, all this really depends on the SIM card you have. I have a regular phone sim. I can send and receive SMS messages. I do not have a Home Internet SIM although I have set two of them up using these same settings. When using the Home Internet SIM, it is critical to clone the IMEI# of the TMHI router. Directions for that can be found somewhere else on this forum but since you said you do not have TMHI, I’m not including a link here.

My phone only gets one bar(many times SOS) and about 5Mbps where I’m located but my GL-X3000 gets 3 bars(5G SA) and between 80Mbps and 140Mbps depending on the time of the day. I couldn’t be happier with the connection since I’m close to a military airport and there are NO cell towers anywhere near me. The WiFi calling has been a life saver with this router

Thanks for the reply. I already tried those settings without luck. (I don’t have a TMHI sim.) I also set the IMEI to my unlocked (TMO compatible) iPhone 13.

What are your IPv6 settings?

The only thing I needed to do as far as IPv6 settings was to simply enable IPv6 and set mode to NAT6 and Automatic DNS acquisition. If you can not connect with those settings, you may have to get a different SIM card from T-Mobile. T-Mobile has so many different plans and I’m not sure that your SIM isn’t bonded to a specific data plan or device. I just simply walked into T-Mobile and added a new line on my business account and only asked them for a SIM card. They activated the SIM and didn’t even charge me an activation fee. They simply said, insert this SIM in your phone and it should just start working. The SIM card you’re working with sounds like it might be linked to a different IMEI number. Where did you get your SIM from and what device or plan does it fall under?

The SIM is supposed to be available for any unlocked TMO device (not IMEI specific). I’ll take it up with the carrier. Thx.

One more thought for you. Have you updated the modem firmware? I’m not talking about the router firmware. I’ve seen issues like this before in other threads. You may need to check the modem firmware and make sure it is running the latest.

One easy way to see if there are any TMO MBN files installed is to run the following AT command on the Modem Management screen:


I’m guessing that you will find that there is no mention of “Commercial-TMO” listed. If not, then you will most definitely need to update the modem firmware.

Sorry to hijack the thread - can you share the settings you’ve used to get Visible working?
I feel like I’ve tried everything and no luck, so now moved over to Mint, which is so far so good.

Thanks! Jon

Thanks! I’ll give this a try.

See Help GL-X3000 Spitz AX Using Visible SIM - #13 by pwyngaard

I changed the IMEI per this thread to an ulocked iPhone 13 (last one with a physical SIM) and TTL/HL to 88. Note the post that states how to lock in the IMEI change after setting the IMEI so it survives reboot. In my case (rural), I band-locked to LTE-only because it was 2x better throughput than the 5G. I am on the $25/month plan. I am consistently seeing ~60Mbps DL and ~5Mbps UL (both of which are very good for where I live).

1 Like