Please upgrade to firmware v2.25 asap

Dear Users,

Thanks very much for your support.

We are happy to to release the firmware v2.25 and you can upgrade from your old firmware.

The new firmware fix an important security bug which can be explored using CSRF attack. Please upgrade ASAP.

The recent change log of firmware:

  1. openvpn bug fix: private passphrase check
  2. add CSRF token
  3. ui bug fix
  4. other improvement


  1. fixed openvpn config errors
  2. fixed various bugs
  3. fixed dns leaks when using custom dns

##v2.241 (removed)

  1. update openvpn version to 2.3.10
  2. remove auth-nocache in openvpn config, which break the connections when reconnect
  3. openvpn support ACE-256-CBC, which is used by some vpn providers recently
  4. fix UI for MT750
  5. added mwan3 for multi-wan management
  6. some other small bug fix


  1. update openvpn config parser (but caused bugs)
  2. fixed various bugs in the UI

How to upgrade the firmware:

  1. You should be able to see a “New” Icon in your old firmware UI. Click it and negative to firmware page.
  2. Click “Download this version” button.
  3. After Download you can choose whether or not to save you configs. If you upgrade from a very old firmware, we suggest you NOT to save config.

This does not affect the clean firmware which doesn’t have GLI UI.

This does not affect the clean firmware which doesn’t have GLI UI.
By "this" do you mean the CSRF issue or are all the changes/improvements in 2.25 related to the GLI UI only and people using your Image Builder would not benefit from redownloading IB and rebuilding the firmware?

Yes. Only our UI.

You don’t need to redownload and build your firmware using our image builder.

Where can we download this update if we are currently using the firmware w/o GLI UI?

This doesn’t affect your own firmware without of stuff.

Right. I want to try out the GLI UI

Upgraded and traveling. WIFI SSID didn’t show up in the network list so I had to connect via Ethernet and do a factory reset. Just in case you are experiencing the same issues as me. All is well at this point…


I experienced the same issues today and downgraded to 2.24. It appears that when I disconnect and power off the router with 2.25 it doesn’t retain the config or the wireless connectivity when it powers back up. I also disabled auto-update on the firmware.

Second day and everything seems to work and be stable with 2.24. Has anyone had similar issues as above?

when you say “2.25 doesn’t retain the config of the wireless connectivity” do you mean the connection is disable after reboot? Does the repeater SSID still saved?

The firmware tries to search and connect to saved SSIDs. If it failed it will disable the repeater.

I simply cannot connect to the SSID I have configured for the router (LED is also disabled). It does not show up. I have to plug into the Ethernet int to manage and reset.

The file /etc/init.d/ssid seems to have been removed from the 2.25 firmware. Could this be the culprit, or was this intented?

@joskevermeulen, the script is renamed to /etc/init.d/gl_init

@wakesk8tr, I forgot to ask which model do you have?

It’s the yellow one.


BTW, it happens with 2.24 also. I may have a h/w problem. Is there anything you’d like me to check?


So I had a little time and did some testing. This may be the intended behavior so let me know. But if the WIFI internet connection isn’t available the router doesn’t broadcast it’s local wireless SSID. So I need to connect to it via Ethernet to change/configure the upstream WAN connection. When it connects successfully it starts to broadcast. Does that make sense?

I would have expected it to broadcast the local SSID so I can change the WAN WIFI without having to pull out a cable and connect locally.


I would have expected it to broadcast the local SSID (even if the upstream WAN/WIFI) is not available so I can change the WAN WIFI without having to pull out a cable and connect locally.</span>

Can this be a feature request for 2.26?

@wakesk8tr, NO. When used as WISP (repeater) mode, if it cannot connect to the host wifi, it should just disable it and broad its own wifi signal. This is called “repeater manager” in our firmware. If your router don’t have this function, you may need to revert the firmware to factory status from the UI and try again. This may happen if you upgrade from a very old firmware and reserved settings.