PPPoE screwed after B1300 latest firmware

Upgrading B1300 in mesh mode is never a smooth experience. Slave unit never gets updated.

Now today I upgraded B1300 manually to latest firmware without touching the unit and PPPoE connectivity is gone.

With messages like check the cable and check your ISP etc I am getting following status messages.

Oops! Cannot detect services.
If you are unable to dial for a long time and try many times have still not been successful. Please try the following methods:
1.Check if the Internet cable connection is normal.
2.Connect your PC to the ISP modem and make the PPPoE dialing for testing.
You shall contact your Internet Services Provider for help after both methods failed.


Sent 50 bytes, received 28 bytes.
Sent PADT
Exit.
Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
pppd 2.4.7 started by root, uid 0


Tried both units with PPPoE authentication and it failed.

Any solution?

So you upgrade the main node manually?

Can you reboot your modem? Like turn it off for 30 seconds and turn it on again.

Hi what’s your previous firmware version? You update to version 3.027 or testing version 3.102?

Yes from 3.027 to latest 3.102. There was also strange behavior for “Guest Network”. I could see tab for it when I was connecting the main unit by first pressing it for 5 seconds and after two seconds I was doing the same for the 2nd unit

But when I was pressing both units the same time for Mesh setup the guest network tab disappears after mesh is successfully established.

Yes from 3.027 to 3.102.

Is there any solution for this? Manually downgrading firmware will be safe?

When you downgrade, do not keep settings and start over.

I have downgraded and didn’t keep current settings but PPPoE still gives the same error which I mentioned above.

Is there any way I can have PPPoE feature working in current latest firmware?

I am on the latest release of 3.102 (previously 3.100) and have no issues using PPPoE. I am running 2 x B1300 in a mesh as well.

The guest network will not operate in mesh mode which is why it disappears when the mesh is connected.

I have tried a number of times, without physically touching the router (means no cable issue) as soon as I upgrade the PPPoE stops working.

After trying the last more recent firmware releases every time I failed to connect with ISP with PPPoE authentication.

As soon as I go back to firmware 3.027 it works. I did tricks turning off router, removing cables and turning on again after minutes but no luck with new firmware.

Not only that I’m missing on latest Adguard feature but also Goodcloud.

I think PPPoE isn’t a priority feature anymore? When many countries still use it.

Sorry but I do not have a clue why new firmware does not work for you. There is nothing changed for pppoe.

I got the same problem with MT300N-V2, the same exact messages in the log after upgrading firmware version from V3.025 to V3.102.
And after reverting formware back to V3.025, PPPoE is connecting without issues.

Any solution?

Thanks

Every time I try to upgrade B1300 or any Gl-Inet router (I have AR750 slate and M300) I face the same issue. On B1300 it doesn’t work on PPPoE after version 3.027.

I hope gl-inet has tested and found it working but I didn’t. I have stopped recommending anyone around me to buy as we have PPPoE protocol with which these devices aren’t working.

Sorry to hear that. But we still do not have a clue that why it happens in your side.

I have to B1300, one AR750s slate and one mt300n-v2, can send my selfie with all these devices :slight_smile:

I have tried that every device on firmware upgrade (in case of B1300 after 3.027) PPPoE isn’t working. This means any feature that is introduced after 3.027 I can’t benefit from. After setting up stubby with NextDNS router loses connectivity 3-4 times a day and I restart it every time.

For the time being, pluging in MT300 into B1300 and setting up MT300 for PPPoE would be a good idea ? I want B1300 to be the main router.