In PPPOE credentials, in the username field, which is the correct syntax?


In in the Vlan Tag, just the number value is needed? As in ‘201’, and not any other syntax?


Depends on your provider. You should look up the credentials and how to enter them.

Mostly it’s like ‚########@provider
VLAN ID is just a digit, no other syntax.

Ok, I tried every variation of the credentials. And tried all of these variations with and without the Vlan ID # which is 201. No go.

Before I post a lot of logging files, can you please advice me on what to work on next? The documentation for PPPOE is pretty thin so after having read a lot of material and searched for ideas… I need to ask for help in configuring for my provider which is Centurylink DSL. This connection has worked fine across 2 different routers so far.



firstly you have to understand if you entered your PPPoE details correctly. You say that it works on other devices, so I would assume that this is the case.

There is no other active device in front of the router, correct?

You can try setting VLAN to 1. I have found the following entry: https://www.reddit.com/r/orbi/comments/w1rdow/pppoe_vlan_tagging_dont_work_with_centurylink/

I have century link/ Brightspeed and I had to turn Vlan tagging off for my fiber to connect. Ppoe is on

Again, thank you for replying, hanging in there on this with me.

Yes, PPPoE is working fine. It is installed on an older Zyxel c3000z router that comes by default with Centurylink DSL service. I switched out routers and PPPoE continued to work fine. So yes, PPPoE is working on other devices.

No, there is no other device in front of the router. It is only connected to the modem which maintains the DSL connection.

I have tried several Vlan numbers based on information I have found serching. And I did find the same link you posted to check out. So thank you on that. I have not tried Vlan 1 yet per that reference, but will shortly.

And yes, I have tried leaving the Vlan value blank as well. No go. If anyone has more ideas on how to pursue this, it would be much appreciated. I continue to research. This is my first experience of PPPoE…

So when you switch routers, you have filled the pppoe username and password right? If yes then I am not sure why you ask about the username because you should fix exactly as given by your ISP.

The vlan ID can be left blank or you can check your ISP.
Googled “Centurylink” and mabye you can try leave it blank or try 201.

Then last, when you change router, your ISP may not accept it immediatelly, you may need to clone your old router’s mac address to the new router. Or just reset the modem, ask your ISP to reset for you or just wait longer time.

On asking about the username… I asked because in research, I have seen comments from users that say they had to add the domain, or remove the domain, or… in other words I have seen a variety of responses. So asked in case anyone knew of this with a Centurylink DSL connection.

Yes, I have and will try again, everything from leaving the Vlan field blank, to at least 3 different recommendations for a value.

The idea of communicating to CL the need to assign the MAC address, good. I will factor that in. Had not thought of that. I’ve had 3 different routers on this circuit which means 3 different MAC addresses and that never created a conflict. But still, your idea is helpful for sure.

And what I have not done is wait. You are correct. I need to wait and give time for systems to train up. This is not something I’ve done so yes, a good reminder.

thankx for continuing to respond to this. If I can just get PPPoE to work, I will have everything configured and then will be able to advance into other settings, but need to nail down this first. Everything else has worked great. And I have really come to love this ‘Slate’ device. Am going to be recommending to people that I know should be running VPN. It is a great device.

Pls let me know if you have update.

If still not working, can you send the log to us via email? support at glinet.biz

I can ask developers to check.

Thank you again for addressing this. I will take all the new notes and apply them tomorrow. And if still unsuccessful, I will yes post log files of the attempts. I appreciate your continued attention to all this. tx

I was able to finally connect to my service provider via PPPOE. It was a matter of waiting, and waiting, and a combination of credentials and a vlan #, and it finally connected. However, it then sat. I finally received a notice along the top bar of any web browser I used… that I needed to “log in” to the service provider’s page.

I have tried various credentials, abbreviations, etc. no go. These are the exact credentials used to log into via a router that does work. (old Xycel into Centurylink). I will contact Centurylink on Monday to confirm the credentials are correct. It seems like it should work… but…

I will also pull logs from this almost connection and send them to the email address you provided. But I am half way there, finally.

I appreciate your time staying with this to help.

And one additional question. I am reading and re-reading documentations but have not found the answer yet. So beg my pardon for the question as I am not being lazy. Have just not found the answer, yet…

In repeated mode, does VPN still work? Or is VPN disabled if configuring/adding the device into repeater mode? tx

Well, I FINALLY got PPPoE to work. Turns out I had the correct credentials, except for 1 character. Lower case instead of upper case. This was told to me by CL support a few weeks ago and I was following this to a T. Which the one character needing to be lower case… of course it would never work. Now resolved. Now very happy. So I can get on learning and tweaking the device.

One question I’d asked but will repeat. When adding a Repeater mode to the device, VPN will continue to work yes? Adding Repeater mode does not disable VPN, correct.

thank you for hanging in there on this.


Afaik yes. But in Repeater mode it will be difficult to access the web portal - a warning will be shown before you can switch to repeater mode.

So I would not really recommend it, even if it works.

I agree. I felt running in that mode is not a wise idea. So I will not go to that method. And besides, I don’t need to now… now that I cracked the PPPoE connectivity issue. Thankx to you… for hanging in there.

It was a pleasure :blush:
If there are any more questions, feel free to ask then :slight_smile:

1 Like