Problem loading Captive Portal AS-750S


#1

I just got back from my trip to Beijing at the Hyatt. Tried to use the slate but the captive portal for the hotel internet refused to work. In the end had to give up on using the router for internet.

Is there something i need to do to get the captive portal to load when connected to the router?

For your information, i tried both wireless AP mode and Wired router mode and both times the captive portal does not load. i have no issues when connecting my laptop directly by wire.

Hope to have a solution since i will be back next month to the same hotel.


#2

You’re not the only one. I also have a AR-750S and on any available firmware version 3.x I cannot get captive portal working on it. This was tested at two separate Hiltons (one in Tigard, OR and one in Arizona). Every time the only way for me to get on is to use an iPhone or iPad to first get through captive portal to get MAC registered, and then clone MAC on AR-750S.

Every time a thread like this comes up somebody suggests changing DNS rebind protection either disabling or enabling - it doesn’t matter. I have changed DNS rebind protection and all the other settings on the same page - cloudflare, etc but changing them does not help nor does rebooting after changing them. Although I have Wireguard and VPN configured, neither of them were enabled either on start-up or at the time I connected.

I believe captive portal is broken on 3.x firmware and have been surprised that I haven’t seen more posts like yours.


#3

I think you must not discard the dns forwarder thats is given. Some captive portal uses dns redirect.


#4

re: this talk of DNS from sammo…I have tried every possible combination of settings in the main Admin Panel GUI that involve DNS including:

DNS Rebinding attack protection - tried both enabled/disabled
Override DNS settings for all clients - tried both enabled/disabled
DNS over TLS from cloudflare -tried both enabled/disabled
Manual DNS Server settings (I have not touched this one as I have nothing manual to input).

What other DNS setting is there for me to try outside of LUCI?

No matter what setting I use above, with AR-750S v3 firmware the captive portal page will not ever appear on the attwifi or hhonors networks that every Hilton and Hilton brand hotel property use when connecting an iPad or iPhone directly to an AR-750S that is itself connected to the attwifi or hhonors network. This is one of the most popular chain of hotels in America and includes Embassy Suites, Homewood Suites, Doubletree, etc, so I think for a travel router to be useful to your average person it must work with this brand.

Captive portal page pops up immediately on both iPad and iPhone if connected directly to the attwifi or hhonors networks without the AR-750S in between. So then I have to get MAC registered via iPad or iPhone and then clone MAC on AR-750S to make the AR-750S work, but I do not think this should be necessary.

As stated before I have vpn/wireguard off for all of this. I am currently on 3.003 firmware but also saw this on 3.001 and 3.002 versions as I tried backleveling in case that helped (it did not).

I hope that @alzhao stays at or nearby a Hilton property for CES 2019 in Las Vegas, then maybe he will observe this same issue and I can have hope for a fix! Or maybe try the Hyatt in Beijing, as @guwester experienced, because I believe it is likely the same issue.


#5

Please try to disable the DNS rebind protection. Here is the docs how to do it.
https://docs.gl-inet.com/en/3/troubleshooting/captive_portal/


#6

Hopefully this was directed at OP because I clearly stated this didnt work for me twice now.


#7

Do you know the captive portal url? If you know it, you can have a try to ping it on your laptop. You will get its IP address.

Add one host entry on luci -> Network -> Hostnames.


#8

I will test Hyatt in HK first.


#9

I just tried and it works with Hyatt.

The only thing I have done is to disable dns rebind protection.

I think you May have made too many settings and too many combinations of trying.


#10

@alzhao It is possible, too many combos or maybe no reboot for one of them. I will drive to Hilton today and retry on 3.03 firmware with all options including dns rebind disabled.

DNS Rebinding attack protection - disabled
Override DNS settings for all clients - disabled
DNS over TLS from cloudflare - disabled
Manual DNS Server settings - not set

If it does not work, I will take a video showing this and put on Onedrive so you can download to see. If it does work, I will ask for forgiveness :wink:


#11

Thanks. You may also do a full clean of the firmware just to test the portal.


#12

@alzhao and @kyson-lok I drove to the Hilton today and recorded my iPad. I have private messaged you a link to a Microsoft Onedrive Video showing how I am unable to get the captive portal page to appear when using the Slate aka AR-750S with DNS rebinding disabled as well as all other options on that page.

I was not able to do a factory reset because the 30-30-30 method did not work, and I saw another page wh ere it said I needed to hold the reset button for more than 8 seconds but less than 20 seconds, and that also did not work…but a factory reset should not be needed anyway because I am not an advanced user messing with settings. Also kyson-lok had something to add a host entry in Luci but as I did not have a laptop I was unable to try that…again it is too advanced for a normal user/customer anyway.


#13

I am asking our guys in the US to test at Hilton.

Got your message and video.


#14

I’m in China now. I’ve been staying at Hilton, Conrad, and Doubletree hotels in Shanghai , Xiamen and Hong Kong.

One thing I did to get around the captive portal issue was to connect first using my laptop and fill out my last name/room number, etc. Then I cloned the laptop’s MAC address on the GL.iNet device, and used it to connect to the HHonors or Hilton Honors networks, and it worked perfectly.


#15

@skydve1x , this same mac cloning process you describe also works for me at Hilton and I did this at my last two hiltons to sidestep the captive portal issue per my first updates. but as you know is a little complex for an average person, I think most people would give up before figuring out how to do that.


#16

The mac cloning actually did not work for me at Hyatt Beijing. After logging in successfully with my laptop and cloning the laptop mac address, the internet still did not route through the Router.


#17

@guwester - did you enable the VPN after you connected??


#18

Hi there, we recently tested the wifi captive portal in a HIlton Hotel in the US. It’s successful! We used a GL-MiFi router (because it has built-in battery and portable) installed with Firmware ver.3.002. Test device is an iPhone 6S plus with iOS ver.11.4.
Process: 1) Connect to router wirelessly; 2) Enter Admin Panel; 3) Scan WiFi and connect to Hotel WiFi; 4) After the success msg popping up, go to Safari browser and visit Bing.com; 5) The captive portal showed up.

Here’re the capscreens:

We also tried Sheraton Hotel with the same device:

We also tried Crowne Plaza Hotel with the same device:

Sometimes, Apple products reject the Wi-Fi connection they failed to connect too many times, just try 1. forget the same-name networks(i.e Hotel WiFi) in your router and the router SSID in your Apple products; 2. Re-do the connection process. Note: make sure your devices have enough power supply ( >15% battery life of your Apple products) and you did disable the DNS rebind protection and other DNS settings.


#19

FWIW, I was in two hotels over the weekend, one via Ethernet and one via WiFi, both Marriott hotels, and I had no problems with getting past the captive portal. I do have all DNS options unchecked and am running FW 3.003 .


#20

I had the same problem on boty my AS-750S and USB150. I found upgrading to the testing firmware (currently 3.013) solved the problem, there is now an option in the bottom right when selecting the wifi network to repeat called ‘repeater options’ under that there is an ‘automatically detect captive portal’ option which when enabled solved the issue.