Problem loading Captive Portal AS-750S

I am glad that this works for you.

Now it is around half:half in my reporting that the portal detection works or not in the testing firmware.

I haven’t had any issues connecting to Hilton properties on mine. There is always the option to clone the MAC address of your phone after getting your phone connect to the hotel’s portal.

I’m supremely disappointed after reading so many affirmations that GLiNet 750S (Slate) recognizes and displays captive portals when connected to wireless hotspots.
My 750S has, thus far, connected to only one captive portal (it was a Hilton). Subsequent attempts to connect at Hilton, Best Western and now Loews have proven fruitless.
I just upgraded to firmware v. 3.022. No change.
Symptoms: After router reboot, I scan and select a local, unsecured hotspot (today: “Loews”) — a hotspot that presents a captive portal if I connect to it, directly from my iPhone, iPad or PC client. I choose Repeater Options: “Auto detect Captive Portal” = On. I verify that More Settings->Custom DNS Server->DNS Rebinding Attack Protection = Off. I reboot the router. I connect my client PC (on which I’ve already performed a “flushdns” to the router and then attempt to browse the internet. I see no captive portal and cannot access any websites.
I don’t profess to be a networking expert, but I’ve years of experience dealing with basic router configs and connecting to hotspots in remote locations.
Pointers as to settings/actions I may have overlooked, appreciated.

EDIT:
As suggested by reply in thread at Captive Portal, VPN Speed on Slate
Solution: VPN->OpenVPN Client->Abort, then reboot the router
Reason: Router attempts to connect to VPN will prevent access to the captive portal. Preventing VPN connection attempts will therefore permit the captive portal to appear.

This looks pretty good - hope mine will work this week at a Hilton Property…

Interesting - Current Firmware I am using is 3.025. I see the “Repeater Options” you mentioned. Mine just says “Auto scan and re-connect” with a Cancel/Submit button. There is no “Automatically Detect Captive Portal” option as you suggest… Hoping I can get this to work with a captive portal…

Interesting I was on 3.013, I’ve now updated to 3.025 which is a production release and the option has gone. I won’t be away for a while to try using it to see how it works for a while but hopefully works.

The new release did add it’s own captive portal so maybe somewhere in there it also detects them.