Repeater Will Not Connect - Stuck with "Getting..." Notification

I have been using my router for 6+ months now and I have connected to dozens of hotels with no issues.

While traveling in Europe, I have been encountering a recurring issue with my router at select hotels. These hotels do not require an active portal. I am able to connect my phone directly to the wifi, and obtain a strong connection, by simply inputting the password.

However, when I attempt to connect via my router using the repeater function, I am unable to retrieve the IP Address, Gateway and DNS Server. Per the image below, it shows “Getting…” indefinitely.

I’ve tried rebooting my router, restarting my computer, phones etc. At some hotels, after attempting these actions 40+ times (yes I will try again and again for hours) I will all of a sudden connect with no explanation but I will need to repeat that process again the next day as the connection will eventually be lost.

I was also able to avoid the issue in one location by connecting my ethernet cord directly into the wall but thats rarely an option.

Does anyone know what’s happening here? It maybe occurs in 10% of locations where I use my router.

*If its not already obvious, I am not technical, so if you have any ideas on a fix, I’d really appreciate it if are able to break it down into very basic steps :slight_smile:

Router Type: AX3000 WIFI 6 ROUTER (GL-MT3000).

Welcome to this forum. This sort of issue has been reported umpteen times on these fora (I have lost count) with multiple suggestions and workarounds mentioned and suggested but with no solid solution or explanation ever given as to why it affect the GL.iNET routers but not appear to occur with other travel routers or wifi devices and client that are also being used during people’s travels to these hotels. I wish someone from GL.iNET could come up with one sensible and reasonable explanation and ultimately with some solution. I have stopped wasting my time trying different settings and tweaks to try and get this to work and have been using TP-Link travel routers instead when travelling.

Have you looked at this (I know you said no captive portal but check the settings):

Yeah & to build off your comment: just because they don’t have a portal doesn’t necessarily mean they don’t lock a device’s MAC/user. Sometimes I think I’m a broken record but I again wonder if cloning the phone’s MAC, that ‘known good device,’ would do it.

There’s just so many different ways a Wi-Fi network can be configured it can be rather maddening.

Exactly the same issue is still occurring. Frustrating that it is not being addressed properly by the GL.

Are you using the MT3000?
We are testing an open source version that may be able to solve this problem, and it should be released in beta next week.

@yuxin.zou yes, MT3000, so far I've tried these versions and both of them failed:
gl-mt3000-4.6.0-r2-2.1-13.20.tar
openwrt-mt3000-4.6.0-0510-1715343790.tar

I have exactly the same problem with networks called mycloud in Germany. All networks with this name do not work on my GL-MT3000. If i try to login with my old GL-AR750S-Ext / Slate i can use the network without problems.

@habakook @buntspext @Upsidedown

pls use this firmware.

1 Like

@alzhao thanks, I've resolved my issue before I had a chance to try your firmware

So this is what helped for me.

The other thread suggested to clone MAC and reuse assigned IP of that MAC address to GL-MT3000 in LUCI section (make IP static). I've tried many many ways to set static IP in LUCI, but nothing worked. Even though all fields showed correct value and there seemed to be no error showing in admin, there was no internet.

So what helped was assigning static IP not in LUCI but in this section:

  1. Join Network
  2. Advanced Settings
  3. Clone MAC
  4. Lock BSSID
  5. Manually Set Static IP
  6. Fill out static ip assigned to the above MAC, hotel gateway IP, hotel subnet, hotel dns

And it worked! again I've tried setting it all in LUCI many times with many configurations, but to no avail. However this worked. Not sure if it is a standard option because I've already switched a few builds in 4.6

The below are screenshots. Hopefully it will help others!

Maybe "Manually set static IP" can solve your issue solely.

I think that the new firmware will fix issues like this.

@habakook @buntspext @Upsidedown

Are you guys able to let me know which hotel exactly you met this problem?
I had feedbacks before and bought the same brand of AP as the public wifi but cannot find the same problem when testing. Maybe the public wifi using a different management system.

Please let me know more places so that we have chance to test in person.

I ran into the problem in networks called mycloud in Germany. They are used at McD/Starbucks/....

After using openwrt-mt3000-4.6.0-op24-0521-1716297051.bin it is working like it should (make sure to do a factory reset!).

1 Like

Will this new firmware be merged into the "normal" snapshot?

Vista Club Apartments, Mallorca

1 Like

Maybe "Manually set static IP" can solve your issue solely.

What do you mean? No need to enter dns and subnet and gateway?

I mean no need mac clone etc. Surely you need set subnet, gateway and dns.