Samba Server remotely and Tailscale

I have been trying to use my Beryl AX as an OpenVPN/Wireguard server but I wasn’t able to connect from outside my network, I opened all the required ports, tried a lot of different ports and it would never connect, my ISP has a Strict NAT and even though I asked them to open the port 1194 they didn’t solve anything, it’s a new local fiber provider on my town so it seems like their infrastructure needs more optimization, I can use OpenVPN as a Client but while traveling I can’t make an inbound connection to my house.

I wanted to have access to my home network while traveling, and especially to my SMB server, I decided to try Tailscale and I really like it, it doesn’t require an Open NAT and port forwarding, at least on my case. I was able to have access to my WAN\LAN resources anywhere through the Tailscale’s tunnel, I even tried to transfer some files to my home network remotely and it worked great.

But, when I connected the Beryl AX to Tailscale, I got a warning because the Tailscale version the router is using has a vulnerability, how can I upgrade it? Do I need to wait an official firmware update to do it? I saw this article; Update Tailscale on the GL.iNet Beryl AX (GL-MT3000) - Jan-Lukas Else I’m not sure if I should wait or do this manually, I prefer stability so I usually wait for the new features (even though I’m testing the alpha version 4.6)

Also, what are your thoughts of accessing the SMB server this way? Is it as safe as OpenVPN? I see not many people is using this and they prefer OpenVPN/Wireguard instead

@bring.fringe18 What do you think man?

Yup, it’s safe.
But the update of tailscale should be addressed by GL @hansome

Like I commented previously this is what I did:

I updated the Tailscale packages through the GL.iNET and it worked! BUT… there is a bug, sometimes when I turn off the Tailscale function on the GL.iNET Web UI, it doesn’t actually turn off and the router keeps connected to Tailscale, and if you turn it off and reboot the router it connects again to Tailscale (having the toggle turned off). I had to turn it off using SSH and it seems to be okay now, now it keeps turned of if I reboot the router.

Thanks, I wish I could use OpenVPN because it’s shelf hosted but I have no option, also, have you tried Tailscale and OpenVPN client at the same time? I know I read there might be bugs but I wonder if people have tried it, I think I’ll use another router just for VPN

Yeah, I second @admon 's thought. @hansome & I ‘spoke’ elsewhere. Firmware 4.5.x is expected to drop 10 Feb. It doesn’t look like it includes an updated tailscaled.

@hansome : Is there any change of getting tailscaled updated into 4.5? That HOW-TO looks like a rather straightforward job.

FYI: ‘tailnets’ are self-hostable.

1 Like

Can’t be that difficult to integrate :wink:

Jan-Lukas’s HOW-TO reads more as a drop in replacement than having to worry about integration. Everything else being equal GL shouldn’t have to do anything beyond that… I speculate.

comments withdraw, things changing.

1 Like


IMO GL really should just pull that feature, stop advertising it & leave it be. Version aside there’s still no option to enable the exit node param, correct?

The kind of person who’ll use Tailscale is the kind of person that isn’t going to have a problem using LuCI or SSH… or downloading a tarball. @admon or I can always write up a HOW-TO… but you guys could really help us all out & get the following (in descending order of importance):

I’ll say it again as I have elsewhere: there’s too much good information being buried in this forum/‘lost at sea’. It needs to be given some information architectural TLC (‘tender loving care’).


I just finished upgrading tailscale to 1.58.2, but that fails to catch up with the release of firmware 4.5. So it will be merged in 4.6.

Thanks @bring.fringe18 @admon for your solution.