How-To: Update Tailscale on ARM64/ARMv7 (f.e. Flint2/AXT1800)

Hi there :wave:

some people wonder how to update the pretty old Tailscale version on devices like the Flint or Flint2. For your convenience, I created a script to automate this process.


Currently, the update-process is only supported on devices using ARM64 or ARMv7 architecture.
This should affect most routers like the Flint or Flint2. If you are not sure about the architecture you can run uname -m to get the current one. It should say aarch64 or armv7l to be able to run my script.

I added some checks in my script as well so it should be pretty safe to run. :crossed_fingers:


You can find it in my GL.iNET forum repo located on GitHub:

:point_right: Direct link to the script

Quick run without downloading

You can run it without cloning the repository by using the following command:

wget -O \
&& sh

Running on devices with low free space

You can use --ignore-free-space to ignore the free space check. This is useful for devices with low free space like the AXT1800.

In that case, there will be no backup of the original files and the script will not check if there is enough free space to download the new files. Could potentially break your router if there is not enough free space.


This script is provided as is and without any warranty. Use it at your own risk.

It may break your router, your computer, your network or anything else.
It may even burn down your house :fire: You have been warned!

Alternative way

You can update Tailscale on your own manually.
Simply get the necessary files from the official website and replace the files on your router accordingly.


To revert the changes, replace the /usr/sbin/tailscaled and /usr/sbin/tailscale files with the original files.

The original files can be found in the /usr/sbin/ folder - they are named tailscaled.bak and tailscale.bak.


Thank you so much for this!

However, sadly on my Brume 2 this does not update my version of tailscale, the script completes successfully but when I go to the tailscale admin page it is still stuck on the old version.

Could you please run uname -m and df -h?

uname -m returns

root@GL-MT2500:~# uname -m

and df -h returns

root@GL-MT2500:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                40.0M     40.0M         0 100% /rom
tmpfs                   495.3M    336.0K    495.0M   0% /tmp
/dev/mmcblk0p7            7.2G    441.0M      6.8G   6% /overlay
overlayfs:/overlay        7.2G    441.0M      6.8G   6% /
tmpfs                   512.0K         0    512.0K   0% /dev

Hmm, that’s strange - all dependencies are met.
Since I don’t use tailscale: Where do you find the version information?

Could you please run tailscale version and tailscaled -version as well?

I add the version given on the tailcale admin console as an attachment.

Screenshot 2024-01-24 at 09.53.36

The output of tailscale version and tailscaled -version are:

root@GL-MT2500:~# tailscale version
  go version: go1.19.3
root@GL-MT2500:~# tailscaled -version
  go version: go1.19.3
1 Like

Thanks for pointing out, I found the bug and updated the script.
You can run the command from above once more - it should work now.

Yes, that works great! Thank you very much.

1 Like

Hi Admon,

I just did the update on the below device. The upgrade worked perfectly on my MT-3000 except that for some odd reason the upgrade didn’t like my device. I’m using a rasberry pi as an exit node and my MT-3000 as a router and I no longer have the internet working. In addition when I run the tailscale status command on my GL-inet I no longer get a direct connection to the exit node (its now trying to use a relay).

I had to factory reset my device and use the older version to get it working.

So thanks for the script but I think the guys at GL-inet might have some configuring to do for the new versions of Tailscale.

Thanks again though for the great script :slight_smile:

I’m running the v4.4.6 of the admin panel.

The script was updated to support --ignore-free-space so it’s able to run on the AXT1800 as well.


fyi - I remotely logged into my other AXT1800 and used this script - it worked flawlessly - withen 1 minute, it had upgraded Tailscale and reinitiated Tailscale without my input / really great work - thanks again


Thanks for the feedback, appreciate it! :star2:

Worked great on Brume 2 and Slate Plus!

1 Like

@admon should this work to update Tailscale on GL-MV1000 Brume or no?

Don’t know, give it a try.

I’m getting this error on MV1000.
“Downloading ‘
Failed to send request: Operation not permitted”

Can’t help you with this, it’s an error on your side.

Maybe wget does not support TLS on the MV1000 or you are using proxy/vpn and block GitHub?

Ok thanks. I am attempting to do the upgrade remotely. I’ll try again when I’m connected to the machine locally and can disable Tailscale and try a different ISP. Thank you for the script. It worked great on two of my gl-inet devices.

1 Like

8 posts were split to a new topic: AXT1800 file system is read-only