Slate AX constantly crashing when connecting client with 5G

Hi. I just got the Slate AX today and it is constantly crashing when any client connects through 5G. It is getting to the point where it is unusable as a router.

The only settings I changed through the GUI were disabling “Prevent weak password” for the admin password (it’s a travel router, I don’t need an especially strong password), and changing the 5G SSID to be named “jul wifi”. Sometimes I changed the router’s DNS to Cloudflare, but it crashes if it isn’t changed either.

I also changed the “glfan” config file located at /etc/config/hosts by SSH’ing into the router, just to include an extra line “option temperature ‘55’”. However, I have been constantly resetting the router’s firmware back to factory defaults, so the changes through SSH should have not mattered. I even checked the file again through SSH to ensure that it was reset back to normal.

I have tried to use the 4.1.0 and 5.4 beta firmware because it apparently fixes things, but the router still crashes.

I have included the log files exported from the router GUI: it is attached as (34.5 KB)

Please help with this issue. This instability is seriously making me consider returning this device.

Edit: fixed typo

Hi, Could you remove previouse crash log, like the following screen shot.

I check the System.log seems repeater is enabled, could you share the /etc/config/wireless config file. More info about the Wifi clients and the AP for Slate to repeater, like model etc.

And pls export log after crash happens again. Better to use 4.1.0 version firmware for log investigation. Thank you very much.

When you initially replied:

The only WiFi clients that were connected at that time were my iPhone 12 Pro and my Roku TV (made by Element Electronics, model E4FAA43R). My iPhone 12 Pro uses randomized MAC address (called Private Address in settings). My 2022 13" M2 Macbook Air laptop is also connected, but through Ethernet, not WiFi.

For other things nearby that may be important, there is a microwave and wireless LED lights connected to an Alexa in my room.

While I was using repeater at the time, I said before that I disabled my repeater. However, if the information is really necessary, I was connected to my college’s WiFi network, through Cisco Aironet 3800 Series Wi-Fi Access Point (AIR-AP3802I-B-K9). It connects through WPA2 Enterprise, with a username and password.

Today, after 3 days of stable behavior, the router crashed again.

For context, I was coming back to my room, and my phone tried to connect to the router while I was nearby. Then, my phone suddenly disconnected, and I check the admin page and see that the router had crashed.

Here is the exported log after this most recent crash:
logread(1) (28.7 KB)

Here is also the most up-to-date /etc/config/wireless config file: (866 Bytes)

Here is what is currently connected:

I feel that the relatively increased stability may be in part due to the custom fan temperatures I set: I followed this information and the temperatures have been consistently at 60F and the router didn’t crash for about 3 days.

However, if you would like, I could reflash the router with 4.10 again and wait for a crash just to prove that my modifications have not contributed to the crash. The router was already crashing before that fan modification anyways.

Another thing that I was trying to do earlier was SSH using VSCode. It consistently failed to connect, but I suspect it is due to an OpenWRT/CPU architecture issue, not the router itself (see this for more information). Apparently VSCode attempts to puts a directory called vscode-server onto the remote server when you SSH into it, but when I checked through SSH later, it did not seem to be there (likely because the connection kept failing).

Many thanks for your detailed description
I tested the same wireless config, runing at iperf3 test for several hours, for lan wan traffic, it works okay.

And I just find a command, could you help to run it at your slate ax CLI.

echo 1 >/sys/kernel/debug/ath11k/ipq6018\ hw1.0/set_fw_recovery

This command will pause the system reboot when a fw crash happen.
And the log will tell more info about the crash. Please help to export that log when crash happen again.
Note that this command can not survive a system reboot.

Hi, my router has crashed yet again. How do I export the log? How do I reboot the router?

Does web UI or ssh still work? If ssh works, use command logread and copy terminal output.

No, neither the UI or SSH works. It just says that I am “unable to connect” to the web UI, and the SSH attempt fails with “network is unreachable”.

Many thanks to kerabite :+1:, now made some progress to this issue. Just to report the debug process.

  1. As for current crash log doesn’t tell enough infomation about the crash.
    We setup up syslog like the following picture,

    After another crash and reboot, get log before crash&reboot here:

The critital info point to the wifi fw bug:

Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] qcom-q6v5-wcss-pil cd00000.qcom_q6v5_wcss: fatal error received:
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] QC Image Version: QC_IMAGE_VERSION_STRING=WLAN.HK.
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] Image Variant : IMAGE_VARIANT_STRING=6018.wlanfw.evalQ
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873]
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873]     :Excep  :0 Exception detectedparam0 :zero, param1 :zero, param2 :zero.
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] Thread ID      : 0x00000067  Thread name    : WLAN TAC0  Process ID     : 0
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] Register:
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] SP : 0x4ba85990
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] FP : 0x4ba859a8
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] PC : 0x4ad7af50
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] SSR : 0x00000003
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] BADVA : 0x00000012
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] LR : 0x4ade1dc4
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873]
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] Stack Dump
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] from : 0x4ba85990
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873] to   : 0x4ba86030
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.448873]
Tue Sep 27 07:21:31 2022 kern.err kernel: [111545.497035] remoteproc remoteproc0: crash detected in cd00000.qcom_q6v5_wcss: type fatal error
  1. After some research, I found a newer wifi firmware by QCA.
    Please help to try it. download it with web browser by click:

Then upload it to /lib/firmware/IPQ6018 directory, and unzip by

cd /lib/firmware/IPQ6018/
unzip -jo
rm -f

Seems this is a compatiblilty issue with Roku TV.

Thank you: I will test this firmware out for a week. After a week of no issues, I will mark this as solved.

1 Like

I’m having the same issue, did installing the firmware helped to solve the problem?

Yes please try downgrading the wifi firmware by the provided command.

Which version should I install? I’ve tried WLAN.HK. - still crashing :frowning:

Sorry, the command in this post is to upgrade. How often does it crash with current firmware or WLAN.HK.

Here is to downgrade:

Usually it does when I connect my second MacBook to the network, so it happens everyday.

The router is in ethernet mode, not in repeater. should I still try to downgrade?


Yes please downgrade to

Unfortunately still crashing…
It looks like it happens when there are many devices connected, and I connect another one.

Could you check the left memory(on page SYSTEM-Overall)? What application do you use(like adguadhome)? Do you use a USB drive with slate?
We could test if it’s the wifi firmware issue or the other issue.