Slate AX constantly crashing when connecting client with 5G

Hi. I just got the Slate AX today and it is constantly crashing when any client connects through 5G. It is getting to the point where it is unusable as a router.

The only settings I changed through the GUI were disabling “Prevent weak password” for the admin password (it’s a travel router, I don’t need an especially strong password), and changing the 5G SSID to be named “jul wifi”. Sometimes I changed the router’s DNS to Cloudflare, but it crashes if it isn’t changed either.

I also changed the “glfan” config file located at /etc/config/hosts by SSH’ing into the router, just to include an extra line “option temperature ‘55’”. However, I have been constantly resetting the router’s firmware back to factory defaults, so the changes through SSH should have not mattered. I even checked the file again through SSH to ensure that it was reset back to normal.

I have tried to use the 4.1.0 and 5.4 beta firmware because it apparently fixes things, but the router still crashes.

I have included the log files exported from the router GUI: it is attached as logread.tar.zip.
logread.tar.zip (34.5 KB)

Please help with this issue. This instability is seriously making me consider returning this device.

Edit: fixed typo

Hi, Could you remove previouse crash log, like the following screen shot.

I check the System.log seems repeater is enabled, could you share the /etc/config/wireless config file. More info about the Wifi clients and the AP for Slate to repeater, like model etc.

And pls export log after crash happens again. Better to use 4.1.0 version firmware for log investigation. Thank you very much.

When you initially replied:

The only WiFi clients that were connected at that time were my iPhone 12 Pro and my Roku TV (made by Element Electronics, model E4FAA43R). My iPhone 12 Pro uses randomized MAC address (called Private Address in settings). My 2022 13" M2 Macbook Air laptop is also connected, but through Ethernet, not WiFi.

For other things nearby that may be important, there is a microwave and wireless LED lights connected to an Alexa in my room.

While I was using repeater at the time, I said before that I disabled my repeater. However, if the information is really necessary, I was connected to my college’s WiFi network, through Cisco Aironet 3800 Series Wi-Fi Access Point (AIR-AP3802I-B-K9). It connects through WPA2 Enterprise, with a username and password.


Today, after 3 days of stable behavior, the router crashed again.

For context, I was coming back to my room, and my phone tried to connect to the router while I was nearby. Then, my phone suddenly disconnected, and I check the admin page and see that the router had crashed.

Here is the exported log after this most recent crash:
logread(1).tar.zip (28.7 KB)

Here is also the most up-to-date /etc/config/wireless config file:
wireless.zip (866 Bytes)

Here is what is currently connected:


I feel that the relatively increased stability may be in part due to the custom fan temperatures I set: I followed this information and the temperatures have been consistently at 60F and the router didn’t crash for about 3 days.

However, if you would like, I could reflash the router with 4.10 again and wait for a crash just to prove that my modifications have not contributed to the crash. The router was already crashing before that fan modification anyways.

Another thing that I was trying to do earlier was SSH using VSCode. It consistently failed to connect, but I suspect it is due to an OpenWRT/CPU architecture issue, not the router itself (see this for more information). Apparently VSCode attempts to puts a directory called vscode-server onto the remote server when you SSH into it, but when I checked through SSH later, it did not seem to be there (likely because the connection kept failing).

Many thanks for your detailed description
I tested the same wireless config, runing at iperf3 test for several hours, for lan wan traffic, it works okay.

And I just find a command, could you help to run it at your slate ax CLI.

echo 1 >/sys/kernel/debug/ath11k/ipq6018\ hw1.0/set_fw_recovery

This command will pause the system reboot when a fw crash happen.
And the log will tell more info about the crash. Please help to export that log when crash happen again.
Note that this command can not survive a system reboot.

Hi, my router has crashed yet again. How do I export the log? How do I reboot the router?

Does web UI or ssh still work? If ssh works, use command logread and copy terminal output.

No, neither the UI or SSH works. It just says that I am “unable to connect” to the web UI, and the SSH attempt fails with “network is unreachable”.