Slate Plus no Internet connection with Tailscale exit node


I have recently bought a Slate Plus, my goal is to have all the wireless traffic to go through a Tailscale exit node.

I went into the Tailscale section in the WebUI and configured Tailscale. After that I am able to access the Admin Panel on its Tailscale IP address. So the connection seems to work. However, as soon as I enable the “Custom exit nodes” switch, all the clients connected to the GL-A1300 Wi-Fi network lose Internet access. I know that this exit node works, as I can use it from other Tailscale-connected devices.

Here are my configurations:

How can I use an exit node with this router?

If I SSH into the router, I can ping external websites and my public IP is the exit node IP. So the router has Internet connection, but not the clients connected to it. How can I fix this?

You should add subnet on the the cloud Tailscale

If you there’s any case for a1300 get offline, please try to unplug and plugin the wan cable.(We should optimize that)

I have enabled it:

Unfortunately, still no Internet connection for the clients.

It looks like the exit node problem that fails to send back traffic via tailscale tunnel. Please try to restart tailscale of the server and check its route rules.

Hi @hansome,

Thank you for your reply. The thing is, that this exit node works just fine if I use it from my laptop or from my phone. In also works well from the Slate Plus SSH console. It’s just the clients, that connect to Slate Plus that don’t get connected to the Internet. Which seems to point at some configuration issue on Slate Plus.

This exit node works as expected when communicating with other nodes themself, but fails to let node’s subnet through. Please check the exit node’s route table to verify if there’s any route conflict.
For windows:

route print

For linux:

ip route

I ran into this issue as well and got it working. My problem was that the exit node is a Linux device, so you have to add the --accept-routes flag when running tailscale. See Subnet routers and traffic relay nodes · Tailscale

I am also running into a similar problem, except I have a Beryl. Using tailscale to connect to exit nodes using my laptop works fine. However, as soon as I turn on custom exit node on the Beryl, internet immediately stops working. The devices I am using for exit nodes are Windows and Mac machines.

I am not sure what to do. I looked around the forum, and it seems a lot of people are encountering this issue. I am not a networking expert, so i dont know how to command line or use luci without some instruction.

1 Like

I’ve been in touch with Gl.Inet support and they tried different options as well, but not this particular setup. I have experimented with multiple different exit nodes and to me it’s clear that this feature is just broken. It seems that Gl.iNet is only testing it with a configuration where the exit node is on the same local network as other devices.

I even see that my Slate can ping external resources and has external IP of the exit node, it is just that it won’t share the connection to the clients.

aligatorzebra thank you for the suggestion, did you add the option when running tailscale on the router or on the exit node? I am wondering because my exit node is also Linux, but it works with other devices, just when the Slate router connects to it, it fails to share the Internet connection to the clients.

@rickyrick do you think you can ssh into your Beryl, when it’s configured with a custom exit node and check that you can ping external websites like google? This way we can verify that your case is exactly like mine and try to convince @hansome that there is actually an issue.

@hansome I am not sure if that helps, but here is the result of running of running ip route on the exit node. How can the exit node configuration be the issue, when it works just fine with my other devices?:

I found the subnet allowed on gl-a1300 has, while you exit node device has also the network of This will cause conflict.
Please change one of the network to a different subnet to locate the issue.

Hi @hansome,

Done! But unfortunately the issue still remains. As soon as I toggle the “custom exit node” switch, all clients connected to Slate lose internet access.

The Slate Plus now sits on 192.168.3.x

I have also adjusted the subnet routes in Tailscale:

Please check some route table with following command:

ip route show table 52
ip route show table 55

Does ping work? Or DNS failure make all clients connected to Slate lose internet access?

It’s not DNS, as I tried to ping by IP as well.

On which device should I run this command?

on a1300, please. can we start remote session for debug?

Hi @hansome, here is what I got before enabling Tailscale:

And after enabling Tailscale. is my exit node.

I can ping from the router.

After having this same issue on a GL-A1300, and buying the router specifically for tailscale. I was able to fix the issue following this guide in the advanced setting section. Tailscale Openwrt

I understand Tailscale is in beta and hope that the gui gets fixed in the next software release, but for now it is working for me.

1 Like

Thank @sgottscho, adding the tailscale forwarding rules to/from lan/wan worked for me. I can use now tailscale with a custom exit node.

Running into the exact problem on Flint GL-AX1800. Tailscale with exit node works on my Android, iPad but if I enable custom node exit on this router, all the devices connected to the router lose Internet. For people who already solved this problem, can you please enlighten us?

@sgottscho that did the trick for me too, thank you so much!

For anyone having this issue, simply configure a custom firewall rule following the screenshots here

1 Like