[SOLVED] Degraded WiFi performance

Hey guys,

Having a problem with the b1300. I compiled from both your repo and the official openwrt repo, and in each case - after compiling and flashing - I get a super degraded wifi performance. It ends up giving me over 120-150ms response on pings, super slow, etc. It gets to the point that the maximum dl speeds I can get is around 25Mbps, out of my 350Mbps connection. Drops like crazy.

Did the drivers change?

I am reverting back to the lede-dev repo that you guys have in your github, but that is quite old. However I have a lot less issues there.

Is this a known issue, and if so - what is the best way to fix it?


Just to add one more thing, dmesg is cluttered with:

ath10k_ahb a800000.wifi: Invalid VHT mcs 15 peer stats

Could that be related?

Also, since I have over 30 units - I have tested on over 5 units, all have the same wifi issue.

Support for the B1300 in “official” OpenWrt/LEDE is only in Snapshot and is therefore not a stable release.
On there you will see:

Development snapshots are automatic unattended daily builds of the current OpenWrt development master branch. Bear in mind that these images are generally not tested, use them at your own risk.

What you are seeing could be one of many issues being worked on.
A new version 18 release of Openwrt is not far away and hopefully we will see full support of the B1300 then.

1 Like

Do you have the b1300? Are you experiencing similar issues? If not - which repo are you using to build openwrt from? It seems for the time being - using the GitHub - gl-inet/lede-source: Mirror of https://git.lede-project.org/?p=source.git with GL patches B1300 repo is the only one that gives me a somewhat working solution, but last time it was updated is a little while ago.


The wifi driver in the openwrt snapshot for this chip is not good. In our default firmware we used Qualcomm proprietary driver.

1 Like

@alzhao - thanks for your response. By default firmware - do you mean the one that comes with the router pre-installed, or the one in GitHub - gl-inet/lede-source: Mirror of https://git.lede-project.org/?p=source.git with GL patches B1300 ? And if it is the first one - can it maybe either get added to your repo, or can I get it? Thank you!

The link you sent is opensource only.

You can download the firmware directly GL.iNet download center

The source code is not publicly available yet because we didn’t separate the proprietary code from GPL code.

Hey @alzhao , thanks for responding , so you’re saying that is the only fully working solution (precompiled image you linked to)? I can not compile on my own, adding all needed packages, I basically have to do the whole setup manually on each device?? Woah, that will make my life a whole lot harder.
Is there an ETA when the Source Code will be available? I can sign NDAs and whatever else is needed, I need to be able to provide a fully working device, not a half-baked unit. And WiFi issues with current OpenWRT are just horrible, making my products almost completely useless.


We can give you image builder. I need to check when we have this available.

Yes, ImageBuilder will be great. I downloaded the one from here, how does one add wireguard for example? And how does one add folders like “/etc/config/*” and all others, similar to placing a “files” folder in root of openwrt git?


For SSH, here is everything you need to know SSH to the router - GL.iNet Docs

Also, here is the imagebuilder which you can use to build images with Qualcomm drivers

1 Like

Thank you. Not sure why you are sending me a link to SSH, but cool :slight_smile:

I already have the imagebuilder on my computer. How do I add wireguard to it though? I tried adding wireguard-tools, kmod-wireguard and luci-proto-wireguard to the images.json file (at V1), but it fails to install it.


I thought you want to put files in /etc/config

OK. I understand you now. You want to have these files in the firmware while using imagebuilder.

You may post your error so that we can have a check.

1 Like

I simply get no installation of wireguard. Also added curl and htop - both are also not added. I must be missing something?

@alzhao I tried adding them under “clean” in images.json and get this error:

Collected errors:
 * opkg_install_cmd: Cannot install package kmod-wireguard.
 * opkg_install_cmd: Cannot install package luci-proto-wireguard.
 * opkg_install_cmd: Cannot install package wireguard-tools.
Makefile:150: recipe for target 'package_install' failed
make[2]: *** [package_install] Error 255
make[2]: Leaving directory '/home/t0ny0/compile/b1300/openwrt-imagebuilder-ipq806x'
Makefile:102: recipe for target '_call_image' failed
make[1]: *** [_call_image] Error 2
make[1]: Leaving directory '/home/t0ny0/compile/b1300/openwrt-imagebuilder-ipq806x'
Makefile:226: recipe for target 'image' failed
make: *** [image] Error 2
Traceback (most recent call last):
  File "./gl_image", line 86, in <module>
  File "./gl_image", line 83, in main
(profile, version, include_ipk, files), shell=True);
  File "/usr/lib/python2.7/subprocess.py", line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'make image PROFILE=QSDK_Premium VERSION=2.27 PACKAGES="-athdiag -luci-hyfi-advanced -luci-hyfi -luci-whc -luci-whc-lbd-advanced -luci-whc-lbd -luci-whc-lbd-diaglog -luci-whc-repacd-advanced -luci-whc-repacd -luci-wsplc-advanced -luci-wsplc -openssl-util -qca-acd -qca-acfg-10.4 -qca-hyctl -qca-hyd -qca-ieee1905-init -qca-iface-mgr-10.4 -qca-libhyfi-bridge -qca-lowi -qca-spectral-10.4 -qca-thermald-10.4 -qca-whc-init - -qca-whc-lbd -qca-whc-repacd -qca-wifison-ext-lib -qca-wsplcd -qcmbr-10.4 -rng-tools -sysstat -ip -ethtool -i2c-tools -iperf -iptables-mod-extra -kmod-gre -kmod-ipt-extra  -kmod-ipt-filter -kmod-iptunnel -kmod-l2tp -kmod-lib-textsearch -kmod-llc  -kmod-nat46 -kmod-pppol2tp -kmod-pptp -kmod-scsi-core -kmod-stp  -kmod-udptunnel4  -kmod-udptunnel6  -libhyficommon  -libieee1905 -libnl  -libopenssl  -libpthread  -librpc  -librt  -libstorage  -libwpa2  -logd  -procd-nand  -uboot-ipq40xx  -uboot-ipq806x-fwupgrade-tools  -uclibcxx -kmod-qca-nss-ecm-premium -kmod-qca-nss-macsec -kmod-qca-rfs -kmod-ata-ahci -kmod-ata-ahci-platform -kmod-ata-core -kmod-qca-mcs -kmod-scsi-core -kmod-shortcut-fe-cm -kmod-shortcut-fe -kmod-shortcut-fe-drv -kmod-qca-hyfi-bridge -kmod-qca-hyfi-iptv-helper -kmod-qca-hyfi-qdisc -kmod-ledtrig-usbdev -kmod-aq_phy wireguard-tools kmod-wireguard luci-proto-wireguard luci-app-adblock adblock" FILES=' returned non-zero exit status 2

Not sure how to proceed. Wireguard is essential for all 30 something units that I have.

Edit: I think ive got it working for now :slight_smile:


just to clarify, it is working now, no need to follow your log?

Correct, I did manage to create it, however it is very buggy when it comes to WireGuard (can not use luci WireGuard interface).

Will there be a newer imagebuilder that will include the wifi drivers and newer OpenWRT source?

I just tested the latest openwrt from today, and I still get barely 35Mbps download and 1.5Mbps upload using wifi, which is pretty bad. When using a direct Ethernet connection - I easily get over 170Mbps. All of this while using WireGuard. To compare - when on your original lede-dev from your GitHub - I can get around 150Mbps dl and my full 30Mbps upload. Again - this is only when using WireGuard.

Let me know if you need any logs, which can help. Dmesg has nothing related to WireGuard.

Just to clarify. Is the only way to get updates to the B1300 firmware to build it yourself? There have been changes made that you can build into your own image but there has been no update since version one (nor any for testing). It would therefore seem that the B1300 only has do-it-yourself firmware updates. .


I am getting this:

When I ping the router ( from my laptop, connected via WiFi - I get max 5ms latency, which is great.
When I ping the laptop from the router - I get latency of over 300ms at times. This is on both 5G and 2G network. With and Without Wireguard enabled. So I guess there is a very serious issue going on. Am I the only one experiencing that?

So it no longer matters if I am using wireguard or not - its constantly going to a dead point. A reboot does not really fix it. A re-flash usually fixes it, until it borks down again.

Any help would be appreciated, as now I am stuck with units, which are not working as they should. Let me know what logs you might need, and I will get them for you.

Thank you.