Spitz 5g with Att

So today I signed up for att business wireless plan at an ATT store. Activated the service in store. Didn’t work with spitz Imei but used the one from my Mudi. Put SIM card in and after a few mins worked in store. Took home and completely stopped working, won’t register. Put SIM card in old Mudi and it worked. Any ideas? I tried to swap imei with AT+EGMR=1,7,"imei” but didn’t work and gave me an error. Any ideas. This so annoying since I signed up for a new plan. Don’t want to have to buy a different router if I can.

Please can clarify more!

  • Are using Spitz AX 5G (GL-X3000) modem?
  • Does your business plan require a special APN?

If you are using the 5G edition of Spitz, try to upgrade the firmware to the latest release, delete all the modem settings by clicking on “Manual Setup” and then deleting one by one.

You may also check this manual at your own risk: https://sixfab.com/wp-content/uploads/2022/05/Quectel_RG50xQ_RM5xxQ_Series_AT_Commands_Manual_V1.2.pdf

Please note that there is no such Spitz IMEI! The IMEI belongs to your SIM not the modem! Moreover, the Mudi modem is a 4G one while Spitz has two different versions: 4G and 5G.

Yes I have the 5g edition. There is an imei for the device’s modem.

My point around Mudi is the sim works and it’s using same apn.

Deleted profiles didn’t work. Also on latest firmware :frowning:

You’re Correct! I meant the IMEI is tied to the modem not the Spitz router.
Back to our main topic: have you tried to connect to the same bands that your Mudi connects to?

Yea. To be clear it worked at the store. When I took it home and plugged back in it stopped. Wondering if since they don’t recognize modem imei it’s back listed. Which is why I want change imei. Don’t think this modem is yes approved by att.

Sicne you know the reason already why don’t you call and unblock your IMEI?! Anyway, you can use this AT+CEER to view the registration error.

Assuming that’s reason cause their system didn’t recognize. No way to get added. Has to come from manufacturer. Sounds like gl.net didn’t get device certified so I have an expensive brick. Guess I’ll return and get netgear

I have come across many users in this forum who are running ATT with this device model, you can check their posts out. good luck!

OK, hoping I can get it sorted out. I will wait for GL.iNET to come online and respond then. I don’t see anyone using it with the new spitz 5g yet. Will keep looking.

I amusing it for over a month and it is quite fast!!! Look at this test:

I even when I first got it, reached 1Gbps! But I was playing at the time with the modem AT commands to optimize it.

Wow. That’s amazing. I think att disabled my account due to the router. Now it’s not working in other hotspot. Have to go to store tomorrow and see what’s up.

I almost reached 1 GB after few tweaks using AT commands! Just now, see the test:

hahaha I just did it after I wrote my last replay! 1 Gbps download speed!!!

1 Like

What are the tweaks you made? Plan I got is unlimited data, but 100mbps limit.

What plan do you have? Maybe I’ll just switch to that tomorrow. Thanks.

In the tweaks I would be interested too :smirk:

So I was able to confirm today that the device did in fact suspend my service. I had to go to AT&T store to reactivate!

I just got off the phone with an agent, they were finally able to add the IMEI. I referenced it as a Quectel RM520N-GL Question to GL.iNet, is it possible because I bought it from the global store that it wouldn’t be registered as a proper IMEI out of the box?

MY speeds are much slow 80 Mbps down and 10 Mbps up, but my plan is unlimited only at 100Mbps max. Which is fine for most things.

Ugh, spoke too soon. Upon reset of device it blocked it again. They are now telling me it is showing as 2G in their systems for some reason and unsupported. Still working to try to get this resolved.

Update: AT&T is insisting it’s not supported. They even went as far as saying they would send me a Netgear router for free :frowning: Of course I would have to setup a new account and lock myself into a contract.

Anyone from GL.iNet watching this thread? Can you please weigh in on whether or not the device is officially supported by AT&T? I know it’s brand new, so perhaps you are still getting it approved? Thanks!

I have already told you there are many ATT users here in the forum! Just use the search function to get all posts!

Yea and I told you AT&T doesn’t support the model, which turns out to be true as well. They won’t support it on the ultra business wireless broadband plan. That needs at cat18 or higher device. Offered to change my plan, but I’m trying to escalate and get it supported.