Spitz AX-3000 compatibility with UK EE

Any UK users have any issues with EE sims?

Upgraded firmware, factory reset, auto-discover APN or even manwell profile configuration…

Sim inside router - no bueno

Sim in handset & tethered via usb - bish bosh

O2 sim works until it doesn’t and it needs a good few hours and a power cycle to connect again.

Lebara (VF mvno) worked fine.

:thinking: :man_facepalming:

I’m having this same issue. I think there’s a EE network incompatibility issue with most third party routers in the last 2-3 weeks. I’ve almost given up and about to send it all back. I’ve tried several sims, all work fine in my phone, no go in my router. my regular phone sim works fine in the router however. I’ve tried tower locks, changing the IMEI, forcing the sim to register but still no go.

In a sense, I think you’re right. IMEI is normally based on a tac prefix that is assigned to a particular manufacturer so I’m assuming either they’ve got a bar/qos policy restriction or a different apn for modems.

It’s been more than a few weeks for me, but I have a feeling it’s a network change related to 5G.

My O2 sim only lasts a few days before that also starts having tantrums so it’s leading more and more towards a hardware fault in this batch of units.

I’ll have a chat with some people and do some digging.

@RJ86 @RubbishUsername are you guys willing to do more testing with our engineers? If yes can you set up a remote environment for us. I can send you guide. But better via email.

Sure, I’ll PM you my email.

Maybe email us directly support at glinet.biz

Yes, more than happy to do some testing.

We got it working. Will post some more info.

Well, it was working…overnight the support team performed a firmware update and now there’s no cellular modem found. it’s tethered via usb to a phone but no sim connectivity, nor is it active in goodcloud.

Oh well. it was good while it lasted.

if nothing, i’ll do a factory reset and maybe fiddle around some more or just RMA it and buy something else.

Can you now share your device to the cloud? We want to see why it registered to the 3g network first

i keep getting the error “connection timeout” when attempting to log in to goodcloud since the firmware was updated

Increase the priority of tethering Internet access

done. please try now

Great! It wasn’t working when I left the house this morning, works by the time I got back. What did you have to do to get it talking?

Yes, please share what the solution was. Thanks.


My device was fixed by support, via goodcloud.

Then I was asked to update the firmware.

That’s when things went downhill.

Device is stuck in a bootloop and no amount of uboot flashes are working.

I’ll now be RMA’ing my device and asking for a fresh box or a refund. Sadly.


It seems a bug for band selection.

Lock/Open to all LTE and 5G NSA bands.
Don’t select 5G SA bands.

@alzhao @ywp

I had to power down and restart the deviec and even after locking to LTE + 5G NSA bands only, my router won’t connect to cellular. It can see the sim card, and the profile & APN is correct, but cycles through connection attempts with no service at all.

can further logs be analysed please?