Spitz AX GL-X3000 - No longer boots

So, I have an X3000 that used to work perfectly fine, but after powering it off, moving it to a different building, and trying to power it back on, it no longer boots - the power LED comes on, and then it just sits there and nothing else happens.

I can't perform a factory reset - holding down the reset button for ten seconds does nothing. I can get it into uboot mode - I've uploaded a variety of firmwares to it, and they seem to flash fine, but then the router reboots, flashes the 2.4GHz Wifi LED two or three times, and then goes back to being unresponsive with just the power LED on.

Any idea what might be happening here? There's no way to SSH into the router since it never boots, so I have no real way of debugging further. Thanks!

Just to rule it out, try a different power supply?

Hi,

Please try the attached power supplier first, or standard 12V, ≥3A supplier.

Yeah, I've tried both the power supply that came with the router, as well as a couple of other 12A ones with enough power. No change.

https://dl.gl-inet.com/router/x3000/
Try the 4.3.0 firmware
Check to see if the modem mode is causing the problem

Same result with the 4.3.0 firmware - updates fine, reboot, the 2.4G light flashes a couple of times and then it goes back to just the power light being on, and nothing working.

Any way to change/debug the modem mode without having an interface to log into?

https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=mediatek%2Ffilogic&id=glinet_gl-x3000

Try this?
If it still doesn't work.
Please check the power supply again
thank you