Spitz Firmware upgrade to 4.4.6 killed my cellular connections

Hi.
I recently purchased a GLX-3000 AX Spitz and it was operating fine for a couple of weeks until I was prompted to upgrade the firmware [to 0406release1 I believe is the latest version].
I did not but should have checked what version was there prior and maybe had a backup of the router saved but I foolishly took a chance and now its an issue to backtrack.

The problem is that neither sim 1 or sim 2 will connect, it always returns with an error that the pin is locked.
I have proven that there is an issue with the router. If I use either sim in my phone they both connect fine.
I have tried all variations of each sim in different slots etc and yet the same error appears.

Can you advise how my might reflash my firmware to an earlier version and what version would you recommend ?
The instructions on the website do not seem to cover this router very well, they cover older equipment mostly and I do not know how to access the firmware gui per se on the Spitz. Do I maybe use the Luci admin setup ?
Would appreciate any help you can give me on this asap.
Thanks and Regards
Laurence

I’ve used 4.4.6 on my X3000 with dual SIMs since it was released at the end of January with no issues.

Sometimes with OpenWRT upgrades (particularly when you skip incremental versions) the config files aren’t automatically/correctly updated and can cause issues. Have you tried a full reset? Try the following steps in order: (1) Power off and remove both SIMs. (2) “Reset Firmware” (in the System menu). (3) Boot the router and do basic setup (e.g. setup the WiFi). (4) Power off and install the SIMs again. (4) Booting up and configure the SIMs.

1 Like

Does your SIM has a PIN code? If not, then the display should be a problem. Maybe can let our developers to have a remote check.

PIN is locked sounds more like “PUK needed now” - maybe you can put this SIM into a phone and try to unlock it there? Does it still work?

HI. Thanks for getting back to me. I did as you suggested and reset from System/Reset Firmware. previously I had used the reset button. But it still has the same issue/s. I also have to connect on ethernet as wireless just will not connect either, no matter after I set/reset/reboot both my desktop and the box, but eth is the only way I can connect to the box, (only after I also drop my wifi). But this is a catch 22, when I tether off my phone its another 192.168.170.0 network issued by isp, but I cannot reset and manually change the box from 192.168.8.0 net not sure if related but another sign its messed up good. Is it an option to somehow revert to an earlier version of firmware and if so what version ? If i do reset lan net to join phone could this maybe allow me to have access to the internet via my desktop and maybe hit reset again, can you force it to go to source for a fresh download or is my thinking way off…
Thanks again for your help.

yes, both sims have a pin code that i enter manually. Always worked prior to upgrade

yes I have done this and the sims always work fine once reinserted into my phone. I enter pin and they both work fine.

I am fine if your dev guys would like to have a check but how can we set up remote access ? I would have to possibly set manual ip to join the ISP lan net issued to me then somehow open a backdoor temporarilly to my desktop ?

So in the manual settings, you have set the PIN correctly but it still display pin need?

yes that is correct, and I make sure i have the correct pin per sim, usually I use one in router and one in phone to tether my connection for now so I know for sure pin are assigned correctly. I have switched on occasion to cross check on say a new reset attempt. Just to reaffirm sims always work from phone when i enter pin.

Asking developer to follow up

Hi,this issue will be fixed in the next version, and now you can try upgrading to version 4.4.3.

Hi. Ok thanks for reply. But how do I downgrade or upload version 4.4.3 when I am on 4.4.6. I can download 4.4.3 to my computer ok but how do I point the router to it when the gui only allows for someone to select “upgrade” and it auto selects the source rather than allowing me to do so. If I have this wrong please advise.

Hi. The suggestion that this will be fixed in the next release is not good enough. That could be weeks away. So, I have found in Luci an option to ‘Flash New Firmware Image’. But I suspect this requires a .img file to load and execute. However the files allowed in the download center for the Spitz are .bin only. Would the upload Luci function allow this or deny it. I do not want to take any unnecessary actions if it may screw the router up even more at this stage, so some advice would be appreciated.

Do you not have a “Local Upgrade” tab available?

Hi. Thx for getting back to me, but no, no tab as such that u mention. Its just a prompt to upgrade or not.

Its " Delete all and Reboot" the only option to select. (Built in autonomy by dev at work, lol)

Did you install plain OpenWrt? So you don’t have the GL GUI at all?

Excuse my ignorance here, but why 2 options to “Upgrade” the firmware ?. Are we not talking about, “Upgrade” is for OS/GUI of the router, is that OpenWrt ?, as opposed to Reset Firmware option in same system menu ?

To confirm, the “Upgrade” does not display any options becuase it says it cannot see any internet connection. Thats built into the GUI/Firmware maybe, Im not a dev or code guy. I can select almost any other window in the GUI from my computer when connected, but bear in mind I can only connec to the router via ethernet and only when I drop my internet/wireless/tether to my G5 connection via my desktop. To connect to the router I drop my tether/wireless and use the eth, even wireless to the router does not respond, even when I set up my own lan wireless setup… if that makes sense