SPITZ GL-X750 carrier aggregation not working


#1

purchased the Spitz GL-X750 hoping to get better wireless data performance since it is equipped with the Quectel EP06-A LTE Cat6 Modem (supports LTE-A carrier aggregation).
validated test results shows not to be working. here is the info of the test setup.

tested on firmware=3.004 & 3.012
Carrier = T-Mobile
equipment setup side by side
LG V30 (LH932) CA 2X2 band getting 60MB
MOFI 4500 SIM4 CA 2X2 getting 57MB
SPITZ GL-X750 (EP06-A modem) NO CA getting 29MB
GL-MIFI (EC25-A modem) CA not supported) getting 25 MB

NOTE: the SPITZ is showing same ~ download speeds as the GL-MIFI which does not have the CA capabilities.

Have anyone with a GL-X750 been able to get it working in a Carrier aggregation environment? really need to know if this investment is a total lost since I already had the MIFI unit.


Slow speeds on x750 with EP06-A
#2

Using the EP06-E i can get 80+ mbit/s on Mifi using a Lan cable to a laptop.


#3

I was in the US and used AT&T network.

I can only get 20Mbps.

What is the reason.


#4

Could it be some setting in the EP06-A that is different to the EP06-E?


#5

Not sure.
Could be that the carrier network problem?
I heard that in the US LTE coverage is quite bad.


#6

If you only had 20Mbps, that is almost the speed pardoin1 had. Almost seems like carrier aggregation was not kicking in.


#7

For EP06 check AT+QCAINFO If modem aggregates two bands, there should be two lines with “pss” and “sss”


#8

Yep had already tried the AT+QCAINFO command and got nothing but an “OK” response.

I was hoping to get some sort of answer as to whether this is a software/modem driver issue??


#9

Seems that the American version does not do aggregation correctly. Need to find out the reason.

Now it is a long holiday and hope to get some answers after the holiday.


#10

Chiming in here, I’m on T-Mobile and could get CA on bands 2/4 with band 12.


#11

CA hasn’t rolled out evenly to all carrier/markets here in the US

I live out in the edge of San Diego, and no CA here, but if I go downtown in to the city center, I see CA available.


#12

So you mean this is a problem of carrier, not the device?

If there is no CA, even those devices claimed to be CAT16 (1Gbps) should be have very low speed, right?

I had an Netgear nighthawk m1 but even cannot connect to network. But it should be a device problem.


#13

Might be - modem is capable perhaps - for the US device, if it’s PTCRB and FCC, most carriers should have a default profile for the LTE Caps at a minimum - ATT and VZW do have innovation programs for startups to get deep certifications - Sprint is odd, speaking from experience, they’re cautious - T-Mobile is a bit more aggressive, but odd bands…

For roaming, they will all likely have a default profile for the modem… and a default for the SIM card based on the roaming agreement with the home provider.

FWIW - for a device manufacturer - the QCOM based wireless WAN cards are the shortest and least painful path for WAN modems - it’s a trust issue with the CPE Lab Managers, who are the ones that approve devices.


#14

what speeds are you getting and what part of the US are you located?
are you using a GL-X750 (Spitz) with the EP06-A modem?


#15

Yes, Spitz with EP06-A. I’m getting 30mbps down, and 10mbps up in LA, West Hollywood on band 2 or 4 CA’d with band 12.


#16

what do you get when running the AT+QCAINFO command.
looks like we or working off the same T-mobile CA bands


#17

I had the SCC (second carrier) on status 1, and then on 2 (active status) when I was running speed tests or heavily downloading.


#18

I’ll second the suspicion that T-mobile does not have CA enabled everywhere. I just rolled out roughly 20 X750s throughout the US and some do carrier aggregation while others do not. When CA is working, I get a response like this to AT+QCAINFO:

+QCAINFO: "pss",650,50,"LTE BAND 2",1,481,-103,-4,-81,16
+QCAINFO: "sss",5035,25,"LTE BAND 12",1,120,-90,-8,-72,0

Otherwise I just get an OK response

In North Carolina, for example, I have a device getting CA with bands 12 and 2. Performance is excellent.

But in Arizona, I have a device flipping back and forth between band 12 and band 4. The band 12 signal strength is higher, but the speeds are woefully slow (0-20 kbps). I locked to band 12 and couldn’t sustain a connection long enough to login via ssh.

So now I’m faced with the decision of whether to disable band 12, since CA is not being applied consistently across the network. It creates a bad experience in places where CA isn’t available but multiple bands are, with Band 12 often getting selected despite poorer performance due to its better CSQ. Is there a way to only enable band 12 as the secondary “sss” band?


#19

I have the exact same problem and the only way around it is to turn off band 12. It’s a shame really, I don’t think there’s a way to only allow band 12 on SSS by looking at the EP06 docs