SQM on MT6000 / Flint 2

I tried to use SQM on my Flint 2 but it doesn’t seem to work. Network accelerator and IPv6 are both disabled. The only configs running on my router are Tailscale and Adguard but I think that these features doesn’t affect SQM right? Im also using 4.5.4 firmware.

ISP average speed:
450 download
80 upload

My SQM settings -

Upload and Download: I tried 90, 85, and 65 percents but all of these doesn’t made any changes at all.

Interface: Eth1 (WAN I believe)

No advanced configuration.

I cannot really say that this is a problem with Flint 2 right now since I can’t find any threads about users using Flint 2 with SQM so kindly share your experience if you tried it. Thanks!

Did you do the SQM test first in wired connection here: https://www.waveform.com/tools/bufferbloat

Yes that’s where I based my tests.

1 Like

It works for me, but I’m using OpenWrt snapshots.

Software flow offloading can be enabled, but hardware flow offloading needs to be disabled.

Same in my case, im using snapshot and this is the result bellow with sqm + layer cake ctinfo:

1 Like

Thank you so much for the response. Will try it again later.

1 Like

I don’t know do I have SQM on my router Flint 2 but test is good

The settings you should be trying is

Download : 414000
Upload: 73600

Make sure that you have cake as Queueing discipline and piece of cake as the Queue setup.

I do have OpenWRT installed on mine using the following settings for my connection

config queue
	option qdisc 'cake'
	option enabled '1'
	option interface 'eth1'
	option qdisc_advanced '1'
	option squash_dscp '0'
	option ingress_ecn 'ECN'
	option egress_ecn 'ECN'
	option squash_ingress '0'
	option debug_logging '0'
	option linklayer 'ethernet'
	option overhead '34'
	option verbosity '0'
	option qdisc_really_really_advanced '1'
	option iqdisc_opts 'nat dual-dsthost ingress diffserv4'
	option eqdisc_opts 'nat dual-srchost ack-filter diffserv4'
	option download '45330'
	option upload '5080'
	option script 'layer_cake.qos'
	option linklayer_advanced '1'
	option tcMTU '2047'
	option tcTSIZE '128'
	option tcMPU '64'
	option linklayer_adaptation_mechanism 'default'

And its A+ for days on Waveform and speed.cloudflare.com Its Great Great and Good can’t be happier then that.

2 Likes

Thank you so much for this.

Just remember that my settings will not work perfect for you, there will still be some tweaking specially as i am using VDSL2 FTTC for my connection which uses PPPoE

Yes I know still thanks!

1 Like

Good day! May I know if this one is necessary?
qdisc_really_really_advanced

and may I know that does it do? The Openwrt documentation doesn’t provide any explanation.

I don’t think that’s needed.

1 Like

Good day! May I ask again if Full Cone NAT affects SQM? Thank you

I wouldn’t think so. However i never tested that.

1 Like