SQM package installation bricks GL-MT1300 (Beryl) firmware 3.200

Starting this thread coming from here: Configuring SQM to reduce Bufferbloat - #13 by arkangelglinet

It seems that both @jxs457 and I have tried to follow recommendations to overcome Bufferbloat with SQM in Configuring SQM to reduce Bufferbloat and found that our Beryl would lockup suddenly after trying to install luci-app-sqm (cannot confirm the installation completed or get any logs since luci gets stuck on the installation in progress message and never recovers).

I recovered the router via Debrick procedure described in Configuring SQM to reduce Bufferbloat - #13 by arkangelglinet (for which I am extremely grateful).

Anyone else with the same issue? Data on what could be the cause and how to get SQM working on Beryl?

1 Like

Same here. Installing it bricks my unit

On my S1300 the guide basically does nothing, so there might be something wrong with the SQM package or it requires something more to work properly…

Hi @Johnex, it might be, but I am stuck investigating since there was no trace of logs after Debrick that I could find and I am very hesitant to try again.

I can tell that the dependencies were almost completely satisfied in at the moment of install, so I am not sure. Here is the step before install in opkg.

Anything that someone can help debug?

Details for package luci-app-sqm

  • Version: 1.4.0-2
  • Size: ~4.0 KB installed
  • Dependencies:
    • liblua5.1.5 INSTALLED
  • luci-base INSTALLED
    • luci-lib-nixio INSTALLED
      * luci-lib-ip INSTALLED
      * libnl-tiny INSTALLED
      * rpcd INSTALLED
      * libubus20191227 INSTALLED
      * libubox20191228 INSTALLED
      * libuci20130104 INSTALLED
      * libblobmsg-json INSTALLED
      * libjson-c2 INSTALLED
      * libubus-lua INSTALLED
      * luci-lib-jsonc INSTALLED
      * liblucihttp-lua INSTALLED
      * liblucihttp0 INSTALLED
      * rpcd-mod-file INSTALLED
      * rpcd-mod-luci INSTALLED
      * cgi-io INSTALLED
  • luci-compat INSTALLED
  • sqm-scripts (17.9 KB) NOT INSTALLED
    * tc INSTALLED
    * kmod-sched-core INSTALLED
    * kernel INSTALLED
    * libxtables12 INSTALLED
    * libelf1 INSTALLED
    * zlib INSTALLED
    * libcap INSTALLED
    * kmod-sched-cake (17.7 KB) NOT INSTALLED
    * kmod-ipt-conntrack INSTALLED
    * kmod-ipt-core INSTALLED
    * kmod-nf-reject INSTALLED
    * kmod-nf-ipt INSTALLED
    * kmod-nf-conntrack INSTALLED
    * kmod-ifb (3.2 KB) NOT INSTALLED
    * iptables INSTALLED
    * libip4tc2 INSTALLED
    * libip6tc2 INSTALLED
    * iptables-mod-ipopt INSTALLED
    * kmod-ipt-ipopt INSTALLED
    * iptables-mod-conntrack-extra INSTALLED
    * kmod-ipt-conntrack-extra INSTALLED
    * kmod-ipt-raw INSTALLED

Luci interface for the SQM scripts queue management configuration package.
Require approx. 42.8 KB size for 4 package(s) to install.

@Johnex ,

I’m running this on a pair of B1300s with great results. Makes me wonder what is different. Both are on 3.105 with these packages post install (in install order even):

What are firmware and packages are you running?

What router model (MT1300?) and firmware are you running @arkangelglinet ? Also what do you get from ls -1 /overlay/use/lib/opkg/info/*.list ? Should produce a list of all packages you’ve installed.

Hi @mmonaghan, I edited the title to make a little clearer :slight_smile:

I have a GL-MT1300 Beryl running on firmware 3.200 with
LuCI openwrt-19.07 branch (git-20.057.55219-13dd17f) / OpenWrt 19.07.4 r11208-ce6496d796

I have no directory /overlay/use/

root@MYHOST:~# ls -1 /overlay/use/lib/opkg/info/*.list
ls: /overlay/use/lib/opkg/info/*.list: No such file or directory
available sub-directories for overlay are upper and work
root@MYHOST:~# cd /overlay/
upper/ work/

The package breaks MT1300 firmware. This has been filed as bug internally.

But as the New Year holiday, I am afraid nothing can be done quickly.

1 Like

In the snapshot GL.iNet download center

installing SQM will not brick the router now. But pls note, in order to install packages, pls remove digital sig verification in /etc/opkg.conf

dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
#option check_signature

On a related note. Without ssh-ing into the route, is there a way with the Beryl to backup your current configuration settings from the Admin Webpage? I’m not finding it. Was hoping to do so in case I brick it again.

Under “More Settings” there seem to be fewer options than on my Mango2.

Yes, the “Admin” link is missing from the Beryl Web UI under “More Settings” I still need to try the direct url to see if if it’s just hiddden.


Thank you for the update @alzhao, and for the updated snapshot :+1:

Is the snapshot stable enough to be used daily? And, can I run a manual upgrade to the snapshot on the current 3.200 keeping all the settings to test it?

Hi @jxs457, LuCI needs to be installed as a plug-in package (see Luci is missing on MT1300 - #2 by alzhao) and you will get it as an Advanced link.

Besides the Wireless Network management (which is not controllable and reports missing/disconnected, apparently because of still not available support of the MTK SoC) and the LED Section that seems to have also no effect (see GL-MT1300 LED control instructions for LED control) all seems to work well.

Why is no one doing integrated Lede firmware? Uboot is not as popular as breed here! I prefer padavan firmware and mt7621a immortal breed

Breed is nice for DIY. But as for a commercial product that should be compliant to industrial standards, this should be not installed by default.

You know more about the device. It’s very difficult for ordinary people to develop and transplant it. Integration is more valuable. The original author doesn’t open the source code and needs to transplant it by himself

Tested the new firmware 3.201 and SQM now installs without bricking the device!

The UI is snappier and I could find no regression.

NOTE: the CPU in the MT1300 appears to be able to handle about 250/300 Mbits/s with SQM enabled.

1 Like