StrongVPN WireGuard + AdGuardHome (on Azure)

Hi All,

My Router: FLINT (AX1800)
FW Version: 3.213



When I point custom DNS to my Azure AdGuardHome (PUBLIC IP), it works fine as long as the WireGuard is not up.

Once I get the WG connection up, there are no more records reaching AdGuardHome.

How can I get WireGuard (from StrongVPN) up and running while continuing to use AdBlocking from my Azure-hosted AdGuardHome.

What is the DNS IP address specified in the StrongVPN Wireguard config file? Is it the Azure AdGuardHome Public IP?

I do not work for and I do not have formal association with GL.iNet


I tried that but it doesn’t seem to do the job.

What else I can tweak?

When connected to strongVPN, run “nslookup” in Windows, which should show the IP address of the DNS server that is actually used.

I do not work for and I do not have formal association with GL.iNet

nslookup returns a DNS IP that is associated with Microsoft but not the Public IP of ADGH on Azure!

What that would mean?


After refreshing the my machine’s NIC, the NSLOOKUP now points to the router private IP.

1 Like

Despite having the router’s private IP as my DNS, there are no DNS queries reach the Azure-hosted ADGH.

Can someone advise?

It seems nslookup in Windows only shows the local DNS on the router, not the DNS through StrongVPN.

Can you open a browser and run a test on or to show the DNS(s) through the tunnel?

I do not work for and I do not have formal association with GL.iNet

Although I put the Public IP of the Azure machine as the DNS of the WireGuard config, the dnsleaktest returns the WireGuard’s endpoint public IP and still no records on ADGH.

As a test, can you try setting the DNS manually in Windows network settings to the Azure AdGuardHome Public IP address?

You have already set the Azure AdGuardHome DNS in the WireGuard config and the router custom DNS … not sure what is left :frowning_face:.

I do not work for and I do not have formal association with GL.iNet

Here are screenshots of all the things I currently have, including manually adding the DNS to the OS.

Still No Luck :frowning:

Is the 20.x.x.x IP your AdguardHome IP?

The router’s private IP as DNS is correct. Because the router will make DNS query to the Adguard Home instead.

Can you post full screenshot of DNS testing of

Another reason could be that, the DNS is not encrypted and it is override by Strongvpn.

Yes. 20.x.x.x is the Azure ADGH Public IP. Screenshot is attached as well.

Encryption is enabled on ADGH. Is there anything I should configure on the router as well?

TBH, I am doing all this effort for one reason, from day 1 I have received my FLINT, I couldn’t enable ADGH locally as it crashes the router entirely every few minutes.

On the router, you need to use DNS via TLS or DNScript to use encrypted DNS. The DNS from vpn config or custom DNS is not encrypted.

For adguardhome on Flint, pls try firmware 3.214 and it should working good.

I have just noticed that OPENVPN works perfectly as expected and everything goes through Azure-ADGH.
But I want to use WireGuard instead due to the better connectivity speed compared to OPVN.

Would that give any clue?

Once I enabled custom DNS, both [DNS over TLS (Cloudflare or NextDNS) / Dnscrypt-Proxy Settings] greyed out.

I have already tested 3.214 and couldn’t notice a much better enhancement in the performance once ADG is enabled locally.

This is the desired behavior.

I don’t know if there is any different between openvpn and wireguard in this case.

Thanks, for your support.

What is the process of getting a refund?