Tailscale issue on SlateAX 4.2 firmware

Using Slate AX latest stable 4.2 and snapshot 2023-03-18 6:03:22(UTC+08:00)

I start tailscale with this:
tailscale up --accept-routes=true --advertise-exit-node --advertise-routes=

this morning slate did not advertise itself as an exit node, rerunning above command remedied that
the I rebooted the router and the same problem occurred, no exit node and no accepted routes.

the firmware behaves like it starts tailescale with tailscale up --reset which removes my added options.

how am I supposed to make my options sticky?


edit: seems to happen when I switch repeater networks as well

1 Like

You can try disable mwan3 that may lead to some conflict I guess.

/etc/init.d/mwan3 disable
uci set mwan3.globals.enabled='0'
uci commit mwan3

I do not use multi wan but tries this anyway.

When I switch network my options are disabled, no exit node and no routes.

Pls try to reproduce.

@manderss99 I got almost the same problem on GL-AXT1800. But I tried to start tailscale in exit-node mode by hands (with SSH). Can you tell a bit more, where exactly did you set up tailscale running arguments? I didn’t find the way how to do it by UI. I should change some init config?

It seems like a popular feature. I believe the UI should provide a way to configure the router as an exit node in tailscale settings.

1 Like

I run this from ssh:

tailscale up --accept-routes=true --advertise-exit-node --advertise-routes=

I agree that it would be much preferable to only be able to use the gui but these options are not available for some reason.

biggest problem is that the options are not sticky during reboot or changing repeater wifi

1 Like

Think I have found the problem,
at the end of /usr/bin/gl_tailscale:

/usr/sbin/tailscale up --reset $param --timeout 3s

this causes my -accept-routes and -advertise-exit-node to be removed
for testing I added:

param=“$param --allow-exit-node --allow-routes”

before the reset command and it seems to be a working workaround

could you please look into this and provide a proper solution for adding extra options to tailscale.
without this it is not possible to run slate as an exit point or to use a subnet router to access internal machines.


@manderss99 I just tried your workaround, and it works like a charm! Thanks a lot. Now I can set my AXT1800 as an exit node, and it still works after reboot.

Just one detail: for me, your example didn’t go right, so I set flag --advertise-exit-node instead of --allow-exit-node --allow-routes like in tailscale docs: Exit Nodes (route all traffic) · Tailscale

So, the result line becomes:

param="$param --advertise-exit-node"

just before

/usr/sbin/tailscale up --reset $param --timeout 3s

And I wanna notice, that if you have enabled VPN client on a router, all your traffic from the tailscale subnet automatically will go thought VPN.

All this stuff still looks like a mmm… not the best solution, I believe possibility to set router as an exit-node should be available “from the box” and by web UI. Maybe guys will fix it sometime, idk :slight_smile:

I was actually able to get Tailscale working on an older AR750S-Ext Slate model, but had to go into the Luci system logs to get the device link because it wasn’t rendering into the UI properly.

I was going to use these directions as a fallback until that ended up working.

logread &/or logread -e $searchString , dmesg gets you the same logs as found in LuCI unless there’s something overriding 'em/custom to the process.