TOR on GL-MT300A and GL-MT300N

Is going to be released a Tor version of the firmware for GL-MT300A and GL-MT300N? Because i’m going to buy one of the mini router according to Tor support. The GL-MT300A is a really powerfull mini router and i will be happy to have tor on it.


Actually this is not difficult. We can make the firmware. Please allow me 2 weeks. Really stuck in some other work.

Was wondering what the status was on this?


Dear alzhao,

I installed the firmware OpenWRT-GL-mt300a-conductor-Luci-1.0.bin
Now Tor works, but stopped working access to the web interface of the router.

Hi, you need to move the switch button to the right side in order to access the UI. And you will not have Tor when you access the UI. After you setup please move the switch back.

Thanks for you answer!

I’m really interested in your amazing project that adds Tor support. I got a few questions and suggestions, as well. As a matter or fact, I’d like to give a donation to you.

Can you please tell me your bitcoin wallet number?

@Tamila, thanks for your donation. We are a commercial company so we don’t take donations now. If you like our products you can give us good reviews and buy more. Thanks!

I have already bought 3 of them - I like their capabilities, physical size and energy consumption.

They also look beautiful :slight_smile:

They have nice Tor support, so I was planning to buy more for my friends who need anonymity. However, I got some questions:

  1. How is Tor provided? Transparent mode, proxy gateway or some other?
  2. Which protocols are supported for Tor - only http[s] or every one?
  3. What is the difference between openwrt-mt300a-tor-1.4.bin and openwrt-gl-mt300a-tor-luci-1.0.bin ? Which is better?
  4. Would it be possible to get the manual or a brief description of the features, to better understand aspects of their work?
  5. Would it be possible to add openwrt-gl-mt300a-tor-luci-1.0.bin to list.txt too?


Tor is provide as transparent mode.

All data goes to Tor.

Check Overview - GL.iNet Docs for details about the firmware. The old luci version only contains luci and 1.4 has a simple UI.


Dear alzhao,

Bugreport: I have found a big problem with firmware openwrt-mt300a-tor-1.4.bin
Apparently, TOR mode only works for LAN interface; WiFi traffic bypasses TOR and goes out “as is”, unprotected, which endangers WiFi users.
Would it be possible to fix that?


Can you test again? Basically wifi and lan are in the same subnet and should behave the same.

When you move the switch to the left, it is in Tor. When you move the switch to the right, you have normal Internet.

"When you move the switch to the left, it is in Tor. When you move the switch to the right, you have normal Internet"
I remember this very well :) Here are the results of testing the router by browser for address :
  1. Switch to the right (Normal):
    LAN: IP = (my real dynamic IP, Ukraine)
    WAN: IP = (my real dynamic IP, Ukraine)

  2. Switch to the left (Tor):
    LAN: IP = (Romania, Tor is works)
    WAN: IP = (my real dynamic IP, Ukraine) - Tor here is not failure!

can you tell me what else you changed in the router settings? For example, did you use repeater, or did you change LAN IP address etc.?

Please, my settings in attach…

… continue -

I just tested. I tried to set static IP and change wifi name as you do.

I don’t find any problem.

Basically the LAN port and WiFi is in the same sub network. The router routes all traffic from this sub network to Tor. So if LAN is on Tor, wifi is on Tor as well.

Are you sure you are not connecting to another wifi network? You can check your phone’s IP address to see if it is still 192.168.8.x if you don’t change LAN ip of the router.

If you are sure. Can you send me the content of /etc/config/network and /etc/firewall.user to have a check?

Please, my 2 configs and command ‘brctl show’ in attach:


Configs in archive config.tar.gz to attach:

From the log I cannot see any problem.

Can you post /etc/config/wireless as well?

What is the configure of your main router? Maybe I need to test exactly the same, even the same setting for the main router.

I don’t have a main router. My GL-MT300A included in the Internet directly.


config wifi-device ‘radio0’
option type ‘mac80211’
option path ‘10180000.wmac’
option htmode ‘HT20’
option hwmode ‘11ng’
option txpower ‘20’
option channel ‘auto’
option disabled ‘0’

config wifi-iface
option device ‘radio0’
option network ‘lan’
option mode ‘ap’
option ifname ‘wlan0’
option wds ‘1’
option ssid ‘MYAP’
option encryption ‘psk2’
option key ‘Urt…7’
option disabled ‘0’