Unable to use NextDNS (manual DNS)

I have been using NextDNS (without DNS over TLS) normally in past but now I always see that my router isn’t using NextDNS, this is confirmed through my NextDNS account.

Manual Configuration is properly done.
DDNS on NextDNS website is set properly and it is working to update IP.

I have set “use VPN for all processes in router” to on, this gives me a working message on NextDNS website but this I don’t think this is the right approach as VPN IP will be registered with NextDNS.


This repeatedly causes Internet going down, I had to restart the router or ON/OFF Cloudflare button in web-admin.

follow the link above and other just below it is basically editing one file ( the file that uses cloud…ti have that service, instead you are going to change a couple of things

perhaps you should go make your own account rather than using the demo one from the nextnds web site that everyone and anyone else is using. you can find more info further down in the thread on how to configure that.

I am using a pro account on NextDNS. Interestingly when I was using free account even the manual (non-TLS) DNS settings were working for me. After paying for the service it worked till I tried it over TLS (Stubby). Stubby didn’t work well so I am trying to revert to manual no-TLS DNS setting.

But even manual DNS settings aren’t working now tried resetting/reflashing the router.

NextDNS dashboard alerts me that I am not using their DNS after every few minutes and tell me that I am using that DNS (referring to VPN). I have correctly set VPN policies though.

what you havent said it that you entered your unique nextdns id inside stubby.

you must replace every
6ffa65
with your own unique id

this works for the free one last i checked, perhaps authentication might be used. I’ve stopped using it and use AdGuardHome now. Not sure if my info is up to date and there have been changes on the nextdns side.

:wink:

when using manual dns you have to set it so it recognizes your real ip address in the nextdns dashboard. your real ip address may have changed if it all correct.

click the “link ip” from the nextdns dashboard

or
click advanced in the link ip section and find:

You can also programmatically update your linked IP by calling:

https://link-ip.nextdns.io/xxxxx/xxxxxxxxxx

You need to check the “over-ride DNS for all clients”.

If you want DNS over TLS, you can edit the stubby.yml file and replace the Cloudfare line with the NextDNS ones (replacing xxxxxx with you own ID):

upstream_recursive_servers:

My IP is automatically updating every minute as I have set to use DDNS from Gl-inet and DDNS is working perfectly fine and IP is linked.

It was perfectly working since months, but when I upgraded firmware PPPoE didn’t work for me. I had to downgrade B1300 to 3.027. Here the problem started and no solution for PPPoE so far from dev.

Have done that already with my own unique ID, have tried “over-ride DNS for all clients”, it works but after a few seconds I get message on NextDNS dashboard that device isn’t using our DNS and mentions DNS of VPN service on router. VPN policies are also properly done.

after is says you are not using it. then go to dnsleaktest.com and run standard leaktest to verify you are actually using nextnds. if it says you are then your issue may lye at nextdns.

just tested it. it works fine. you are doing something wrong. (i even used the stubby.yml info I posted.

nextdns recognized my client
All good!

This device is using NextDNS with this configuration.

and dnsleaktest was

207.246.91.188 dns.nextdns.io. Choopa, LLC

make sure you are not using a windows editor with cr/lf use something like nano or vi
start all over.

I have reset my router and using the manual entry of DNS servers from Web UI (the very easy way) nothing with router OS.

I am sharing my vpn policies, DNS servers set, DDNS.

Edit: If I disable and re-enable some settings like “DNS for all clients” nextDNS starts working again for next few minutes.

  1. are you using it where vpn is enabled and connected?
  2. post your stubby.yml file

since you’re using Android, is your Private DNS set with something else?

what client and what router

Does you VPN .ovpn file have any DNS settings in it such as “push” or “block”?

This page might help:
https://forums.openvpn.net/viewtopic.php?t=28008

It is sent with nextdns.