Update Adguard on Flint 2 MT6000 Router

Hello there;

What is the proper way to update Adguard that is part of your MT6000 Flint2 Router?
I have tried a couple different ways, each time I had to Flash my router to get Adguard working again.
Which of course it flashes back to the original
I really do not want to keep flashing my router.
My Router firmware version v4.5.6
My Adguard Version v0.107.26
Upgrading it from within the plugin app breaks it.
I also tried to upgrade it from using WinSCP and getting it from Github

Using AdGuardHomeLinux arm64.tar.gz
It was already broken I tring diiferent things and not really knowing whatI was doing.
Do you have clear instruction on how to update and/or which file to use to update if the Plugg-in app inside the router does not work?
Thank you.

Don’t do it if you don’t know what you are doing. It will cause trouble.
Just stay with the current version on the router - which is fine.

If you know what you are doing: Adguard Home Upgrade - #6 by slesar

1 Like