USB devices not recognized


I have a new AR300 which is not recognizing anything plugged into the USB port. I have flash drives and portable hard drives to test with and it can’t see anything. This devices was supposed to provide wireless access to my USB drive but so far it’s been very disappointing.

Check the format of the usb drives. Also you can try logging in to the console (ssh) and seeing the output of dmesg when you plug it in. I have a flashdrive and portable harddrive plugged in to my b1300 through a usb 3.0 hub and they work fine. A different usb harddrive i tried needed too much power and the usb port could not supply it so it did not work without a powered usb hub.

The format of the drives are fine. The portable hard drives I have are formatted MBR. I am good with Windows but I know nothing about Linux so I am not going to be able to log into any console that way and know what I am looking at. I have decided to return it as non-functional

It should be just fine for USB storage.
What is the exact model you are using? AR300M? Lite version? pls specify a link.

MBR should not be a problem. But it should have a valid format, ext4, ntfs or fat32.

For the log, it is easy to find in advanced settings (luci->status->system log).

I agree it should work. It worked the first day with firmware 2.26. After an upgrade to 2.27 it no longer worked. All of the USB drives have a valid format. They have data on them.

The device is the GL-AR300M16

Can you tell me the format of your file system?

You can also flash the old firmware v2.264 back if the storage really don’t work on 2.27

The drives are formatted NTFS . I don’t really want to flash back the firmware to fix this. That means I can never upgrade if needed.

Has there ever been a resolution to this? I received the GL-AR300M16 (16MB Nor Flash) a few days ago. I upgraded to 2.27 shortly after initial power up. Everything is working great including VPN functionality, but USB port acts like it doesn’t exist. I have tried all different types of USB sticks, hard drives. powered ports, with correct formatting, etc. all without any hint of recognition.

Is reverting back to 2.26 the only option? Should I return it?

I returned mine. After I flashed back to version 2.26 it was dead. This device is simply too hard to operate for anyone but top level Linux people. I am still looking for a new device

I have downgraded the firmware to 2.264. USB port appears to now be working. Not sure what I have lost in other capabilities though.