Using Flint 2 with StarLink

I use a Flint 2 replacing the original StarLink router. How do I add a static route to 192.168.100.1 so that the Starlink app will work on iOS WiFi clients?

It shouldn’t be needed. All connected device to a router are - in normal cases - reachable automatically.

Can you please explain a bit more in detail how your network looks like?

It is this scenario: Using a Third Party Router

There is a StarLink app for mobile devices that allows you to see StarLink link information, stats, etc. without the static route the app is not able to connect to the web server supplying the info. All the smarts are in the antenna, the StarLink router I am replacing with the Flint 2 is being bypassed. Hope this is explains the setup, I am currently not on the boat and therefore have no immediate access to the router.

I would say that all traffic will be sent to WAN port anyway when the router does not know any additional routes. Do you use VPN? What is the local network of the router?

Are you getting a public IP via the WAN port from the Starlink “modem”?

Nope, no public IP. It is dynamic.

StarLink says:
“To access the status of the Starlink antenna from within the local network, you must configure a static route to send all traffic for 192.168.100.1 to the WAN port to which the Starlink is connected. Then you can use a web browser to view the Starlink dashboard at http://192.168.100.1

I can get to the dashboard via WAN but nice and handy to have it via the app. So I guess the issue is that the app is “hardwired”.

I’m not sure if this works.

Go to the luci interface. Make a backup of your config (System- Backup/Flash firmware)

Then go to network → routing

And add a static route

1 Like

If the website works but the app doesn’t, then the app uses something different from just the IP to access. Not an routing issue then.

Thank you, I will give this a shot
:slight_smile:

I belive that wan is dhcp, should be automatic and gateway is 192.168.100.1

Hmm im going to wild guess.

But i think the app expects the same subnet as the starlink router.

In that case i think the only solution is setting up flint 2 lan as a dhcp client.

Please make a backup before doing anything and then try changing the protocol to dhcp client for lan in luci.

You could also choose to remove one port from br-lan and configure that port as your maintenance port with a different interface and dhcp so you dont have to reset it or have to find back your routers ip :smile:

Basicly for firewall you dont need anything like that you probably want to make some sort of dumbap setup similar as bridge mode.