VPN not working

Dear Team,
Out of the blue, my Flint has stopped using VPN. It was working fine until a couple of days ago, but now it just ignores VPN.

I have tried using it as Guest and non-Guest, to disable and enable it again, restarted, changed WG pair keys. Everytime I check IPleaks my actual IP is leaking. My VPN app is working fine btw. Firmware I am on 4.1 also tried 4.2 beta3.

I am quite disappointed by the experience so far.

Which VPN provider are you using?

Have you enable this option?

Could you export debug info like here.
Or we could start a anydesk remote session?

That would be SurfShark

hi @hansome I have tried both enabling and disabling but no luck. I did check your suggestion. When enabled, at some point I had VPN enabled on both guest and private vlans (only guest is selected to use vpn) which I did not want but after reboot neither has vpn again (still allowed access to wan option enabled). luckily I have the application running and did not have any issues.

I will try to get the debug and post ot here

Here it is
ipt.zip (17 KB)


Thank you very much for helping debug. We find some clues on “Override DNS Settings for All Clients”.

Do you use manual DNS(not from DHCP) with your PC?
Does leak happen other than dns query? Could you send your configuration backup to handongming#gl-inet.com

Much appreciated your help.

Hi @hansome ,
Thank you for your reply. On my ISP modem I think I have quad9 ( and its alternative) as DNS servers. I have always used them. I don’t think I changed that on Flint but I will check and get back to you asap.

Ipleak is only showing my real IP address.

How can I get the configuration file and how can I send it? You mean to post it here?


Please go to luci page:
and click:

Send it to my email: handongming@gl-inet.com

Thank you.
That zip file though contains personal information though. Are there any specific files that you would like to have? I can sent those.

After more investigation, I found the most import setting is to set you PC’s dns server to, the router gateway).

Also enable following option to prevent leak when vpn disconnected by accident.

Hope you test it okay, and I don’t need configration file to analyze more.
Thank you.

1 Like

Thank you @hansome
I have tried your suggestion and seems to work. i will keep it like that for a while and see if everything goes according to plan.

Thank you again!

Edit: I stand corrected. It now gas issues with resolving urls. Not working. Reset both modem and router and reset dns on modem to the ISP. Looks ok for now but not sure for how long.

have you enabled overide dns ?

Yes, of course.
Not sure what went wrong.

Now it is working fine (isp dns). Hope it will last. I have removed kill switch option though as it was not very stable and having that enabled i would need the pc in order to revert.