WAN gateway incorrect / not updating in WISP mode

I was having trouble at an internet cafe today getting WISP to work. I could connect to the cafe’s wifi, but couldn’t get to the internet. When looking at the GUI, I noticed that the ‘Gateway’ in the Repeater Connection information was in my home router’s IP range (well, kinda… it’s set to 10.4.10.0 which is odd in and of itself).

I tried connecting to a couple of other different networks - one was a friend’s guest network, the other was an xfinitywifi network. In all cases the ‘Gateway’ in the Repeater Connection information had the same 10.4.10.0 gateway. (see the ‘xfinity.png’ attachment). It never changed.

However, if I look at the LuCI ‘advanced configuration’ when on the xfinitywifi, I see what appears to be a proper gateway (10.224.0.1) which is not my home network (see attached ‘LuCI.png’).

Is this a bug, or is this normal? A bug? And is a problem… i.e. could this be related to why I couldn’t get internet working at the cafe I mentioned earlier? (I’ve gotten WISP to work on several other networks… one at home, my friend’s guest network… but something wasn’t working at that cafe, and I don’t think it was a login page - they don’t have one there).

FYI - I have OpenVPN configured. I tried looking to see what happened to the Gateway when it was on and off and there was no change.

Thanks.

GL-MT300N-V2 (2.264 and 2.263)

SOLVED.

I figured out what was going on. I had a static route configured for my VPN which was on the wwan with the target network 10.4.10.0/24. I didn’t need it. Got rid of it. That changed the gateway I was seeing in the UX to what I’d expect. :slight_smile:

Thank you kindly for bothering to report the solution.