WAN to LAN leakage during boot on Flint AX1800 firmware 3.213

Hello,
I am a customer of GL.inet Flint AX1800 router. I am running firmware 3.213.
There is an issue with the router that during booting before the OS starts, the router switch is working and acting as switch which lead to leakage of DHCP packets from the WAN router side (I have 2 WANs) and confusion in the network until all devices in the network are disconnected/reconnected after boot to get proper DHCP from the Flint.

I saw a commit on GitHub referencing this issue in GL-inet openwrt fork repo, and I wanted to report that this issue is present in Flint as well.

If there’s any workaround I can apply in SSH let me know, for example to keep the switch disabled until OS boot then enable the switch after VLAN/ interface setup. I saw some code in shell scripts with delay_lan_power variable somewhere near /etc/init.d/firewall.

Seems it is a problem before Kernel is up so you cannot do it via ssh.

This problem was fixed in some other chipset but may not Flint.

@alzhao perhaps it can be adjusted by modifying bootloader nvram variables ? But you need to be careful to avoid disabling the debrick LAN method (which will need the switch to be reactivated).

You are exactly correct! This is the only way we are trying to do.

Hello, is there any news, is the 4.0 uboot image containing a fix for this ? or 3.215 ?

Still no update. We will send out a uboot once we have.

@alzhao still no update ? this is a very important issue.

Uboot uploaded to GitHub - gl-inet/uboot-ipq60xx: uboot src and binary for GL-AX1800 and GL-AXT1800

Pls download uboot and verify the hash.

Pls update uboot in uboot failsafe mode 192.168.1.1/uboot.html

Issue solved. Thanks.

2 Likes

Oh woah thank you!

I actually had the same problem, but nobody could figure it out. Not here & on the TP link forum😅

I’m not a pro so I didn’t explain the problem correctly. Thanks to you I can finally use my Deco’s in AP mode💖

Trying to compile the uboot image, following the steps provided on the github, I keep getting this error:

ca@CA-Ubuntu:~/uboot/sdk32$ make package/feeds/base/uboot-qca-ipq6018/compile V=s
awk: include/scan.awk: line 21: function asort never defined
awk: include/scan.awk: line 21: function asort never defined
awk: include/scan.awk: line 21: function asort never defined
awk: include/scan.awk: line 21: function asort never defined

configuration written to .config

make[1]: Entering directory ‘/home/ca/uboot/sdk32’
make[1]: *** No rule to make target ‘package/feeds/base/uboot-qca-ipq6018/compile’. Stop.
make[1]: Leaving directory ‘/home/ca/uboot/sdk32’
make: *** [/home/ca/uboot/sdk32/include/toplevel.mk:181:
package/feeds/base/uboot-qca-ipq6018/compile] Error 2

Can anyone help me out with this, or share the file directly?

The uboot file is in the git repo.

@alzhao would that be the .bin file?

The tutorial said it was a .mbn file, so just verifying😄

@alzhao I flashed the .bin on 192.168.1.1/uboot.html, looks like everything is still working😄

However, the uboot version says it’s 20220710 on the uboot page. On the file itself it say’s it’s 20220711.

Does this mean it didn’t flash correctly? I tried 2 more times without change🤷‍♂️

1 Like

Maybe it is just timezone difference.

After uboot change, is the problem solved?

1 Like

Seems to be yes. No leakage after rebooting the flint & leaving AP enabled!:sparkling_heart:

I updated mine too and it seems fine.

Has anyone encountered any problem? I’m thinking in update my other AX1800

1 Like

No issue after updating uboot for many months now

1 Like

Same. No issues after flash.

1 Like

what firmware you are using with the flint? in the latest beta firmware the qos is working? what kind of problems you find? thanks