Why can't I access my MT-1300 via an ethernet switch?

Apologies if this is a noob question, but why can’t I access my MT-1300 through an ethernet switch?

When my MT-1300 is directly plugged into my BT Hub 6 router (LAN port to LAN port), I can access the MT-1300 at from my PC, which is connected to the BT Hub via an ethernet switch.

However, if I unplug the MT-1300 from the BT Hub and plug it into the ethernet switch, I can no longer access the MT-1300 web admin page (nor its USB share) from my PC.

The BT hub shows that the MT-1300 IP address of has moved from port 2 (the original direct connection) to port 1 (the ethernet switch connection) as expected. But any attempt to access that IP address from my computer just times out.

Ok, this is weird. I have another 8-port switch directly connected to the 16-port switch mentioned above. If I connect the MT-1300 to the 8-port switch, it works!

Could it be an incompatibility with the 16-port switch? I tried 3 different ports on it. It’s a Zyxel GS1100-16. The 8 port is a TrendNet.Teg-s80g.

Is there a networking explanation for this?

At a guess I think you might have an address conflict, but I think more information is required, and in particular whether the Beryl is in router or AP mode, and what your address scheme is.

The BT Hub I assume is your main router, so it is running a DHCP server handing out addresses to everything plugged in to its LAN port(s). Those are unmanaged switches, so everything plugged in to the switches will get addresses from the BT Hub. The BT Hub itself is going to be the default gateway, and most likely will have a xx.xx.xx.1 address. Let’s say for the moment that is, and it is handing out addresses in the range.

The Beryl in router mode ordinarily has a LAN address of, and also runs a DHCP server that will hand out addresses in that range. So the first puzzle is how it comes to have a LAN address of, and how that fits with the BT Hub network. The switches are agnostic about what traffic they pass, I think. So the first thing is to figure out if the Beryl is in router mode and if you have two DHCP servers at work (a bad thing) and what their networks are.

Thanks for the feedback. The Beryl is in Router mode.

The BT hub is my main router and is and gives out DHCP in the range 64 through 253. It reserves 1 through 64 for static IPs. The MT-1300 defaults to so I had to change that to to access it on my LAN. The BT lists it with static address I have a home heating network server device which is listed by the BT hub as static IP, so the lower static addresses work.

I have not been able to use the WAN port on the Beryl, I don’t understand why. The only way I can get the Beryl to connect to the Internet is to connect to my home WiFi in repeater mode, but I don’t need it to connect to the Internet for my purposes (a remote USB drive for backups).

Okay, then this is the first snarl. The Beryl is acting as a DHCP server handing out addresses in the .1.x range, and so is your BT hub, on the same physical network. This will never work.

Reset the Beryl to defaults, and then plug its WAN port into one of the switches. Then, connect a PC either to the LAN port or by wifi to the Beryl. It should pull a 8.x address and you should be able to connect to the Beryl at the 8.1 address. Then, see what the WAN port has been assigned. It should be some .1.x address. If not, you may have a defect in the Beryl. Then come back for more.

Ah, thanks so much for this. It seems completely obvious now! Apparently too obvious even to include something similar in the GL.iNet getting started docs :smiley: No wonder the WAN port didn’t seem to work as my PC was upstream of it.

I reverted the Beryl back to, connected the WAN port to my BT Hub and a LAN port to my PC and checked that worked.

So bearing this in mind, can I even do what I want? In other words using Beryl as a backup device in my loft next to my 16-port switch. If I have the Beryl wired via WAN to my 16-port switch how can I connect my PC. Can I have two ports (WAN and LAN) connected to the switch, or am I limited to Beryl’s Wifi?

Or if I connect the Beryl to my switch just via a LAN port, how can I get to it from my PC which is on a different subnet?

Or if I revert the Beryl back to so I can access it just via a LAN port as before, how can I stop it acting as DHCP and conflicting with my BT hub? I can’t change the working mode unless a cable is connected to the WAN.

Good that the Beryl seems to ok. I think there are a couple of ways of approaching this. Full disclosure: I use my Beryl as a travel router and not as a file sharing device, so I’m hoping someone with actual knowledge will jump in.

If all you want to do is file sharing within your home network, then you can leave it in router mode. You’ll want to connect to the Beryl on its LAN side to manage it. On its LAN side it will be a DHCP server, but you don’t care about that. You can connect the WAN port to one of the switches, and its cabled connection will pull an address from the BT Hub DHCP server in the 1.64+ range. You don’t want that, so you can either change the Beryl WAN connection to static, and supply your 1.1 address on the WAN side, following the setup instructions, or you can set the BT Hub to hand out the same address to the Beryl every time it connects. I favor the latter, since helps avoid conflicts. Now go back into the file sharing configuration, and set the configuration to share files with WAN. Here WAN doesn’t mean the whole world wide internet, just the side of the router that is your 1.x network handled by the BT Hub. I think that will allow you to do what you want.

The other way would be to put the router into access point mode, which turns off the routing function and the DHCP server.

The first way may be easier, because you can unplug the travel router from your home network and the USB drive, and use it as a travel router without making any other changes. If you leave the USB drive in, just remember to change that WAN sharing back to LAN sharing.

Thank you, that worked! I opened the USB share to WAN and connected Beryl WAN to the BT Hub. The BT Hub assigned DHCP and the USB share was available there. I set the BT Hub to always use that address, then connected the Beryl WAN to my 16-port switch and after first failing to connect, a quick power cycle on the switch fixed things and the USB share was available.

Just one slight issue remaining, I can’t get to the Web admin panel. Trying to browse from my PC to gives “This site can’t be reached. refused to connect. Try checking the connection. Try checking the proxy and the firewall”

Do I need to do something with port forwarding now?

The web admin panel is on the LAN side at, and that 1.175 address is on the WAN side where the rest of your network is. So you can do a wired connection to the Beryl LAN port with a computer, or the Beryl’s wireless, and browse to 8.1.

Or, maybe there is a way to make it available on the WAN side, but I think that is a bad thing if you might ever take this on the road.

Yes, I just read it would be a bad thing too. However, while it’s on my home LAN I could do it temporarily whenever I need to access the web admin page. Would that be forwarding just port 80 in my BT Hub?

Alternatively, I could enable Beryl’s wifi and access it that way?

Ok, I see a solution already on this forum to access the web admin panel via WAN. However it looks like something I really don’t want to do. I’ll just connect a laptop via LAN or bring the Beryl to my desktop.

Thanks for all your help, I’m all set.

Agreed. That’s best. You want to avoid port forwarding on the BT Hub if you can and never ever forward port 80.

A router has a firewall and controls traffic between its WAN side and its LAN side. Port forwarding punches a defined hole in the firewall, so forwarding port 80 on the BT Hub would have allowed a device in the interwebs hitting your port 80 (which probably happens hundreds of times an hour) to be forwarded to something on your LAN. But your Beryl isn’t presenting its web interface to its WAN side (the Hub’s LAN side)