Why is my bitrate so low?

Hi, over the past few days I noticed speed test results averaging around 70mbps where previously I was getting around 120mbps. I initially put this down to my VPN provider as they have been having issues lately but while checking through settings I looked at Luci and saw that my 5Ghz network is only getting a bitrate of 150mbps despite being ethernet connected directly to a 1Gbps router on a 500mbps ISP subscription. Presumably this isn’t supposed to be the case but I could very well be misunderstanding things completely. Any advise is appreciated.

Try changing the 5GHz channel on the router (e.g, to 40, 44 or 48).

I do not work for and I am not directly associated with GL.iNet


Mine is changing

1 Like

But isn’t 80mhz the fastest by default? I can’t see how 40 would be quicker than 80 but again maybe I’m misunderstanding.

Mine is still at 150, I’ve never seen mine say anything that high

The bitrate is automatically negotiated using signal strength. Upto channel 48 are normal channels. Above that are DFS, limited but offer channels outside the normal range which can improve signal quality and strength.

Try higher channels or move the routers closer together.

1 Like

I tried higher channels and it made no difference, once I tried 164 (if I remember correctly) it just broke everything and I had to physical rest. The Flint and the ISP router its connected to are literally side by side and I’m not far away from those either, with wifi6 and 4 antennas I expected it to be higher than 150mbps. @alzhao has the same channel settings as me too but has much better speed. Mr Alzhao, can you please tell us how close your Flint and ISP routers are and how close you are to them? Thanks

I don’t understand what this has to do with the issue. In the original post it mentions that the ISP router and the GL-iNet router are connected via ethernet.

1 Like

I know but Shivadow mentioned that bitrate is determined through proximity so that was my answer.

I am using repeater. The Slate AX is 5 meters from the main router.

I guess the bitrate relates to all the clients connected to the router. So you can list what devices (including repeater to the main) router. Maybe there is something you can find.

Maybe just disconnect repeater and other client, only connect your phone to the router’s 5G WiFi and check.

1 Like

The channel number (e.g., 36, 40, 44, 48) is not the same as the channel width (e.g., 20MHz, 40MHz, 80MHz, 160MHz).

1 Like

So to be clear this is ethernet at 150mbps or 5g wifi at 150mbps?

Is this with AND without VPN or any other overlords?

1 Like

5G wifi with Ethernet connected and giving results over multi hop VPN so it will be slower than real wifi speed. 150mbps is what it tells me for bitrate, I used to get an average of 120mbps on speedtest but now getting an average of 70mbps. The subscription I have is for 500mbps so I was expecting much higher.

Hmm, I’m using router mode as I was told ethernet can carry data faster than sending from ISP router to Flint to client.

Not sure if the vpn might be restricted at the router…

Using wifi and ethernet at the same time to the same router won’t offer any benefits unless you have Link Aggregation compatible setup.

Otherwise vpn is out of my comfort zone. So with that… I’m fired.

1 Like

This is what the set up looks like to me, I was told that the ISP router can transfer data to the Flint faster in router mode via ethernet than in repeater mode from ISP router wifi to Flint wifi so that is what I went with. I’ve no idea about Link Aggregation but I’ll look into it as a potential benefit.

In modem mode there less weight on the cpu in the router so theoretically yes, but no. It matters not because the router is benchmarked before release. You use modem mode to rule out things like firewall etc interfering.

As far as I know vpn speeds are limited at the gli router but to confirm it you’d have to do the research as I don’t do vpn. I have no need for it.

1 Like

Apparently it can do 667mbps which is 167mbps faster than my subscription speed so it should have the ability to do high speeds, the VPN provider I use has also been rated one of the fastest and can do 1gbps in test run videos. I will probably just leave it in modem mode due to my doubts about wifi being any better. Your help is much appreciated though obviously.

There is a discrepancy between the maximum VPN speed stated in the User Guide (667Mbps) and in the Product Description (500Mbps for WireGuard, 112Mbps for OpenVPN):

In general, the stated maximum VPN speeds would only be under ideal conditions and I almost never reach those VPN speeds in real life (the same applies to maximum 2.4GHz/5GHz WiFI speeds).

This is almost always the case and I have never reached WiFi speeds higher than the real-life Ethernet speed of >900Mbps through a 1Gbps port.

In the Admin Panel screenshot, it appears the client device is connected to the GL-AX1800 over 2.4GHz WLAN. It does not appear that 5GHz WLAN is enabled. Can you confirm?

To rule out WiFi as the cause, can you connect a computer via Ethernet cable to a GL-AX1800 LAN port and run SpeedTest to see if it can get higher speeds?

1 Like

I am definitely connected through 5G wifi, the 2.4G wifi is a guest network for other devices. Unfortunately I can’t do a pure ethernet test as I only have a tablet and no ethernet compatible device.