Wifi connection problems on GL-MT300n-v2

Hi,
I have a problem with my new GL-MT300N-v2 Mango. I have on my normal AP two Wifi networks: 1 unsecured and 1 WPA2 Personal/AES. I can see with iwconfig on my “Mango” that it is connected (tested with both) but I get no IP and on my APs I see the “Mango” as connected but without IP.
When I open a hotspot on my iPhone and try to connect with it, it works without any problems.
I even tried to disable the Wifi for clients on the “Mango” without any effect. What can I do to further debug? Can I check anything on CLI? I have the newest firmware installed. I reset the “Mango” different times. Has anyone similar experience?
EDIT: other devices can connect to both of my Wifi networks :wink:
Thank you.
Best regards
Marcus

Ok I found out it is related to my used TP-Link Omada APs. All other APs are working. So I think I have here a special configuration on my APs and need help to debug it. So if you have any ideas how I can find a way to debug this please let me know.

Can you give details of your wifi settings on the ap that Mango cannot get IP?

Hi @alzhao,
I have problems with my TP-Link EAP-225 controlled via Omada. These APs have a central configuration:

  • 2 SSIDs both 2.4Ghz and 5Ghz
  • all rates are allowed
  • 1 SSID has WPA2-PSK with AES
  • 1 SSID is open
  • both SSIDs have the same problem

With tcpdump I can see that the udhcpc requests are send and reach my dhcp server. The DHCP server sends a reply but that reply never reaches the Mango. Are these information enough or did I miss anything? Please let me know.

Hi @alzhao
here are screenshots from the two ssids and their configuration.
WPA2 SSID

Open SSID
Screenshot 2021-06-04 at 16.03.03

Does the psk2 and open wifi has the same SSID? or different?

These are two different SSIDs.

Please provide the captured file.

tcpdump udp -i apcli0 -w test.pcap

Hi @JerryZhao here is a test file. If you need more or other information please let me know.
test.pcap.zip (374 Bytes)

Please dump eth0

tcpdump udp -i eth0 -w test.pcap
root@GL-MT300N-V2:~# tcpdump udp -i eth0 -w test-udp.pcap

tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes

0 packets captured

0 packets received by filter

0 packets dropped by kernel

This is the output after one minute.
I ran also a tcpdump without “udp” this is test-all.pcap. I hope that helps you.
Archiv.zip (1.1 KB)

I hope you can dump a normal packets with your other device.

As I mentioned before on these two problematic SSIDs on my EAP-225 APs I can only send packages but I receive none. This is what we see here.
What should I simulate to get the result you want try to curl an url?

Should I send you a dump file where you can see that the DHCP requests where answered on my DHCP server and the answers are send back? As a proof?

Please show:
# ifstatus wwan

root@GL-MT300N-V2:~# ifstatus wwan
{
“up”: false,
“pending”: true,
“available”: true,
“autostart”: true,
“dynamic”: false,
“proto”: “dhcp”,
“device”: “apcli0”,
“data”: {

    }

}


This is what my Omada Controller tells me at the same time.