Wifi Sometimes Keeps Turning Off and On

I have my router AR300M in Repeater Mode. Basically I am repeating a Wi-Fi signal. The problem I am experiencing is that sometimes the WiFi Signal disappears then comes back on and keeps going through this on and off cycle. I have to switch off and on the router a few times before this settles down. What could be the problem?

Ditto here.

Same problem here with the AR750, but only in some environments. Very odd.

When the router has problem connecting to the main router, it will try to reconnect and this will affect the AP as well.

Put the router in area with good signal and try again.

Same issue here. Was testing AR300 performance and it kept doing the same thing. Was in same room as main Access Point.

one more thing, be sure to upgrade to the latest firmware.

I’ve experienced same or similar with my AR300M in WISP repeater mode when it is in the same room as Comcast Xfinity WiFi signal it is repeating. When this happens, I observed the available SSIDs in the area from an unconnected laptop. AR300M was -33db, about 12 other SSIDs, including 3 or 4 hidden Xfinity signals, 3 private Xfinity signals and 2 public Xfinity signals(each related set with unique but sequential MAC addresses), and a neighbor’s refrigerator were -85 to -72db. If the AR300M SSID was visible, within a few seconds, my Xfinity SSID would disappear and the AR300M would lose internet connection. About a minute later, the Xfinity SSID would return and AR300M dropped out. Clients could connect directly to Xfinity gateway, except for the AR300M which remained unable to rejoin. The AR300M network page just perpetually showed “reconnecting”. Each time I manually disconnected the AR300M or rebooted the process would repeat, with the AR300M sometimes supplying internet for a short time, sometimes just going through a perpetual connect/disconnect cycle.
Moving the AR300M so that at least 1 wall was between it and the source WiFi eliminated all problems. I suspect some kind of constructive /destructive or multipath interference but do not have the means to confirm.

I have experienced similar thing when trying to connect to weak signal Xfinity APs while traveling using phones, laptops, or other wireless routers, so I doubt the issue is with the AR300M. It has rarely happened while trying to connect to other infrastructure WiFi that has multiple APs but a single SSID such as airports and hotels, but public xfinitywifi SSIDs have been the worst. Usually the SSID will stay up long enough to sign in and pull a small amount of data for a couple seconds then disappear for 20 seconds, come back up and make you sign in again. I do not like the fact that Xfinity Gateways broadcast so many different signals including multiple hidden ones that cannot be turned off. That could potentially be contributing, but I cannot confirm.

I do not know if the cause of these similar but different situations is the same. Hopefully this additional information will strike a chord with someone that will recognize what is actually happening.

Thanks for the insightful information.

You mean it has problem with both of your private xfinity wifi and public xfinity wifi, right?

Sometimes you cannot put the router too close. There is some close distance effect which the signal is actually interfere. At least 1 meters away.

Same here with mt300n-v2. Whatever the distance the repeater keep scanning and does not connect.

I saw errors about libiwinfo-lua: Luci WiFi monitoring complains it is not installed even if it is and the Luci icon for the signal strength always signs zero, even for the network…

because of the wifi driver, luci is not so compatible. Luci is just the UI not the working driver.

The signal strength is a bug.

Yes, it did have problem with both private xfinity wifi and public xfinity wifi.
After upgrading from 2.264 via web interface and running firmware 2.27 fine for a few days, it stopped working. Would no longer connect and I noticed that changes applied in Luci stopped ‘sticking’. I used the web interface to load a fresh clean version of 2.27. It appeared to load, but there is no longer any luci web or ssh interface. uboot is present, the old version that only loads nand firmware. I tried to roll back to openwrt-gl-ar300m-clean-2.264.img from uboot. It went through the motions, displaying “update in progress” and the spinning wheel.
But neither the ar300m lights nor the activity light on my ethernet port flickered for over an hour when I finally gave up. No change, still wont do anything but show the uboot screen on I tried MTU of 1500, 1200, 900, 600 but to no effect.
Any idea what else to try? I’ve added the serial pins now, anticipating the need to upgrade uboot, but I’m nervous to try that without directions.

You can refer to the docs Advanced Uboot - GL.iNet Docs

The commands to upgrade uboot, firmware is run lu and run lf

The most important is setting up a tftp server.

If you don’t upgrade uboot, it should be quite safe.