Wifi6 routers, 5G channels and country codes

Both GL-AXT1800 and GL-MT3000 have issues connecting to 5G channels when delivered. Surprised there are many issues reported by new buyers but not much talk about the issue being the default country code setting… For the GL-AXT1800 i see people wasting time looking for fixes in the wrong places.

Both are travel routers right?

After figuring out the issue, I was able to change the country code on the GL-AXT1800 and it does now see and connect to all channels.

Unfortunately I didn’t find any way to fix the issue for the GL-MT3000, changing country in the config file has no effect…
Where am located most 5G wifi are on channels above 64… GL-MT3000 unusable as it stands…

@alzhao, please get us a fix asap!

Thank you!

See my response to your comment in another thread on the same subject. I suggest you continue in that thread, see GL-MT3000 Beryl AX - No Country Code Option in Luci? - #11 by SmurfonToast.


Hi,Is this repeater mode? If so, please enable ‘Allow Repeating Of DFS Channels’ on the repeater menu.

Will fix this issue asap.

Repeater mode, DFS enabled.

Enabling “Personal Hotspot” on IOS devices will use a channel above 64 (at least here so it is) and impossible to connect from a MT3000.
If you enable “Maximize Compatibility” on IOS, the “Personal Hotspot” will be on a 2G channel and MT3000 can connect… but then why did I buy a WIFI6 router ?

Really need a quick solution to repeat channels above 64 and if there is none please say so, wasting precious time on this confusing issue… !!

Thank you!

I understand your frustration, but I really hope that comment is directed at GLiNET. There have been a number of folks on this forum who do not work for GLiNET, myself included, that have genuinely attempted to help you out; even if the result is not what you wanted.

This has been fixed in the snapshot one wee ago.


1 Like

BTW seems to be working just fine.

Not so fast :frowning: This 4.2.1 Mar-22 snapshot was so unstable constantly dropping repeater WiFi on my Beryl AX on both 2.4 and 5G that I’ve rolled it back to 4.2.0 stable for now.

Update 31/mar/23:
I’ve been trying again 4.2.1 release 2 (stable) for two days and I found that I previously using the wrong country code.

Now I can connect to the correct 5g hotspot channel (DFS) and it’s pretty stable.

If anyone reading this and using the travel router abroad, here’s a list of country-channel mappings someone shared with me on another thread: What channels are supported in both the 2.4 GHz and 5GHz band in most countries?