Wireguard Client not working on 4.2 Firmware

I have a Wireguard server running on router with the 3.2 vesion. To this router I have multiple devices connected as clients. I upgraded an opal to the 4.2 version (sanapshot), and I find it imposible to make it work. I have reset and reinstalled the firmware many times. I just do the basic as setting the minimal things to the router, configuring the wireguard client and it doesnt work. I do not reach the server network, neither I can reach the internet trough the server.

I have reviewed the configuration such as: Global Proxy, Block non-VPN trafic and many others but I cant make it work.

Is this happening to more people?


What’s the Wireguard server service provider? Could you show the config file masked keys and endpoints?

Hi, My server is a GL-MT300N-V2-6c9, that I´ve configured, here are the details:

Here the clients configured in the server:

On the clients side. That I have a mango and an Opal (which is the one that doesn´t work) I have:

Thanks for the help

Seems opal connected once.
Could you try to change listen port on opal?
And please run following command if it still not work

ifconfig wgclient


I changed the port. But still the same problem.
The OPAL connects to the server, but the traffic does not reach its destination. I can not reach the internet on the devices connected to the OPAL. The OPAL connects trough a VPN to the server and the server should provide internet access and access to the local network in at the server´s network. This works fine for the other devices (routers) connected to the same server.

The server states that the Opal is connected but is like the connection is not working

Thanks for the help!

Here is the result of the commands you gave me:

Does pinging an IP on OPAL work? Or does only the DNS query fail?
Please add the output of these commands:

ip route

Is it convenient to take a look at the remote assistance?


I also did a ping to the server ( and it works. The network in the opal is:
The opal is within the home network (that is the ISP router)

Yes, we can do remote assistance. How is it done?

Here is the result

I have just compared the ip route to a client that does work and is different:
The server ( is within the network


My theory is that when the client is activated the file containing the routing is not automatically updated.
Would you agree?

Added this info latter:
Here is more info on the routing on a client working and on the one not working.

How do I make the router to automatically update this info like in the other routers. It seems that is what is not working


For remote assistant we need to use anydesk
can you pls pm @hansome to arranage a time?

Hi @alzhao

Your colleague @hansome told me via PM that he was going to get an Opal to test on his side what I’m trying to do. I sent de details on what I have done.

Besides, the problem arises when I connect to the VPN and there is no access to the internet. Via any desk you cannot review what is happening because connection is lost

Besides, I don’t feel comfortable giving access to my computer via AnyDesk. But I’m happy to do it via zoom or by providing a temporary access to the router

Hi, I tried with my OPAL it works.
Please send me this debug info.


This is the version I have


And I’m attaching the info.
ipt.zip (21.5 KB)

Thanks for the help. Rodrigo

And I did an update to the next snapshot version, but still the same.

We have addressed the bug related to OPAL OpenWrt Firewall3 compatibility with some firewall rules. I will inform you when it is fixed. Thank you for your feedback and help with debugging.

1 Like

Fantastic! I´m glad this is helping you in the debugging process

1 Like