Wireguard Client To Client Communication Issue

Hi to everyone, I’m a new user!
I have searched and read discussions started by other users with similar issues and followed different suggestions found in the web, but, unfortunately, due also to my limited experience in networking, without success.
I have two Mango GL-MT300N-V2 in my network, as shown in the attached picture. One of them configured as Wireguard server, the other as a client. Server is connected through WAN port to my ISP modem/router with public static-IP. The modem forwards traffic received at the port 51820 (Wireguard) to the server.
The Mango client is connected to Internet through a LTE usb dongle and an IP camera is connected to its LAN port.
In the client I have configured a port forwarding that redirects all the traffic received from the Wireguard network at the port 8080 to my IP camera at port 80.
In addition, I have another client in my smartphone through the Wireguard APP.
From the server I’m able to reach my IP camera without issues. No luck from my smartphone. From my smartphone I’m able to ping the server IP address ( but not the other client’s IP. I know that it is necessary to configure another port forwarding to obtain client to client communication: I have followed different solutions as described above but without success. I’m able to modify files inside Mango by WinSCP.
Please could you help me? If necessary, I will paste here my firewall, network and Wireguard files.
Thank you in advance for the support!

Did you add to AllowedIPs in the WireGuard configuration file on your phone?

Thank you for the answer :+1:
I did as suggested but unfortunately without success :pensive:

I am not sure if this is a problem with the phone. Can you test it on a PC using the same profile and check the routing table?

same issue, I’ve created another user, now I have:

  • Cam
  • Mobile
  • PC
    From PC I was not able to ping also the server, then I have added to the Allowed IPs in the PC configuration and now I’m able to ping it. Adding (the IP address of the Cam Client) to the PC configuration, nothing change, always unable to reach the Cam Client.
    During my tests, I have followed the suggestions reported Here . In my network configuration is not defined the interface “wg0”, then I have read this guide to create WG server manually but, always without success.
    I hope that links above could help.
    Thank you!

Can you look at the routing table or trace the leap point on your PC? Use these commands to check that when you access, the data is correctly forwarded to the WireGuard tunnel.

# Windows
route print

# Linux

As visible in the screenshot, the Wireguard interface is enabled and both IP addresses (both in allowed IP address of Windows-PC Client) (Server) and (Cam Client) are routed to IP (my Windows-PC Client).
Launching traces, only the first one to the IP ends successfully.
I’ve tried a test with Open VPN and everything works fine, but performances are lower than Wireguard as expected :roll_eyes:

I notice that you have added a new node to the PC. have you tried to see each other between and

The default MTU value of OpenVPN is 1500 and for WireGuard it is 1420. Maybe you can try changing the MTU value.

MTU should not matter as Traceroute packet sizes are typically small.

This is very likely the same Wirguard LAn access issue here:
Wireguard Client failed access to GLiNet Wireguard Server Lan (firmware 4.1) - GL.iNet (gl-inet.com)

You are setting Site-2-Site setup. You need to mange the routing on each node.

You cannot ping from one Wireguard client to another Wireguard client withoug setting the routing.

Pls use our cloud managed solution to set up S2S network.