X-3000 Lock to 5G towers

I am on vodaphone Germany, and my connection sometimes flips from 5g to LTE in the middle of streaming of video chat, causing severe latency/lag. I am trying to block the LTE bands using the 'masking' feature:

I have also tried the "Lock Tower" button to lock to a 5G tower, and I get the same result. If I lock to a 5G tower, the SIM card won't register.

However, whenever I mask the LTE band, my SIM card is no longer able to register on the network. Is there a way to mask the LTE bands while allowing my SIM to register on the network?

5G NSA needs LTE to be enabled. You should enable Open LTE and 5G NSA bands.

Okay, 5G NSA is dependent on LTE(4G) for VOICE/SMS so if I block LTE it won't connect.

But the problem is DATA will often switch to LTE, resulting in terrible performance. Is there a way to lock just the DATA to 5G, while allowing for voice/sms to stay on LTE?

AT+QGMR

Can I see your module version number?

RM520NGLAAR01A07M4G_01.201.01.201

mkdir /firmware
cd /firmware
wget https://fw.gl-inet.com/download/RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200.zip 
unzip RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200.zip -d RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200
QFirehose -f RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200
reboot

try upgrade

I have successfully performed the upgrade. Is there anything else I need to do to lock DATA to 5G NSA?

Don't set it. Leave it at the default

After using the BETA firmware for about an hour, I notice that the firmware does stick to 5G NSA tower a little bit longer than the older firmware, but it will still often switch to 4G tower automatically.

Is there no way to lock just the DATA to stay on 5G?

Is the 5G signal bad?

Signal seems good. Not sure why the router will occasionally bounce from 5G -> LTE and then back again.

Here's the historical signal strength. You can see that the modem switched to LTE for about 10 minutes:

 AT+QMBNCFG="list"        --View the mbn file selected by the current sim card('+qmbncfg: "List",0,1,1,xxxxxx')
 AT+QMBNCFG="AutoSel",0   --Turned off auto select and deactivate with
 AT+QMBNCFG="Deactivate"
 AT+QMBNCFG="Select", "ROW_Commercial"
 reboot

Switch the mbn file

1 Like