X3000 repeater captive portal

I have a problem with a hotspot, with my x3000 (repeater mode) I’ve tried everything, including “Mac clone”, but the login window for the hotspot just doesn’t open? Does somebody still have an idea? I didn’t have such problems at all with my old x750!


Try disabling AdGuard Home and Custom DNS servers
And please make sure to disable DNS Rebinding Attack Protection within the DNS settings.

Everything set like that…

It seems to be still connected to the cellular network - this could be an issue here. Try without cellular.

Are you sure there will be a captive portal?

1 Like

Have you tried navigating to http://neverssl.com to trigger the captive portal?

1 Like

I’ve already tested it…

Oh, let’s just blame it on IT security. Sorry @admon but could not resist!. To the OP: hope you get it sorted soon with helpful advice from the experts here.

1 Like


But the issue here is different. The whole Wi-Fi connection does not work, there is not even a IP for the repeater. So Captive isn’t the main problem.

1 Like

My first post after getting the GL-AXT1800 when it first came out. You can write a whole encyclopedia (if you have got the time or energy) about attempting to fix the vast amount of problems with using these routers in “repeater” mode. Even stickier issues than those that I have experienced when trying to negotiate captive portals:

1 Like

Unfortunately it still doesn’t work, can’t anyone from support help?