AR-750 won't reconnect


#1

I’m using an AR-750 (firmware 3.009) to bridge a wifi hotspot to a wired LAN. the WIFI hotspot drops connection several times per day. The AR-750 never automatically reconnects when the hotspot comes back. In the best case, I have to log into the AR-750’s admin page and manually choose the wifi network again. In approx 30% of cases, the AR-750 becomes unresponsive and has to be completely rebooted.

How do I get the AR-750 to automatically reconnect when the source WIFI re-appears?


#2

Which band did you use for repeater? 2.4GHz or 5GHz? There are many customers feedback the repeater cannot reconnect after v3.005. We are investigating this issue now.


#3

Thanks for the reply. The hotspot is dual band. I will have to look if I can disable one band.

It’s easy for me to reproduce. Let me know if there are any tests I can run to help.


#4

Consider that a WiFi bridge has to have following …

  • Same band : 2.4 or 5.0 Ghz (if the uplink is a isp router you can disable one band)
  • Your AR-750 on the other bridge side has to have the same SSID
  • Both devices have to have the same encryption
  • If possible set both devices to the “same” channel

But you said that the uplink is a “hotspot”, so you mean a free public WiFi ?

This could be the problem, depending on the configuration of the hotspot, the leasetime and/or keychange time of the encryption. Maybe the two devices are not working synchronized.

I hope I could help you with my post.

PS: Some free/public WiFi provider (of course like every WiFi spot or CELL towers for mobile phone) have a more or less restrictive connection rules.

If the max connection # is 1000 clients and you are #999, at the moment you loose connection and another client connects, you can re-connect. Another possibility is, that the provider blocks your MAC adress after X hours, for maybe a long time.

Do you have this problem only at this example or wherever you create this WiFi bridge?

Maybe you could set up a cronjob in LUCI to change the MAC adress of your 750 every 30-60 minutes?


#5

Thanks for your response, but I don’t believe that’s the problem. The hotspot is a jetpack 8800, which is essentially a cellular modem I use for access while traveling. It works reasonably well, but drops and restarts its wifi transmission several times per day. Unclear at this time whether that’s due to loss of cell connection or simply a software bug in the 8800. there’s a thread on that elsewhere. Regardless, after it glitches all of my devices successfully reconnect to its wifi except the 750. (Due to the 750’s instability, I’ve had to redirect most of my wireless devices to connect directly to the 8800 rather than through the 750. My wired devices, though, rely on the 750 as a bridge)

Upon reboot, the AR-750 connects fine to the 8800. Once the 8800 restarts the wifi, though, the AR-750 will never reconnect unless I manually log in to the 750 and join the saved network or I reboot the 750. Since the 750 autoconnects fine following a reboot, it seems unlikely to be a channel or band conflict. There is definitely no limitations or management of MAC addresses configured, and all other devices auto rejoin the 8800 fine.

Furthermore, in some instances following a disconnect, the 750 becomes completely non-responsive. You can’t access the admin page. It does not respond to pings.

This appears to be two software bugs in the 750: one that occasionally locks up when the source wifi signal is lost, one that fails to attempt to reconnect (or stops attempting to reconnect too soon) when the source wifi signal is lost.

Ironically, it happened again during the writing of this message. I have a ping -T running in a command prompt. First the pings were successfully completing. Then the I received a series of timeouts when the 8800 dropped its wifi. Then I received “PING: Transmit failed. General failure” when the 750 locked up. The PC lost it’s gateway (as reported by ipconfig), the lights went out on the 750 and it remained non-responsive until I power cycled it. Upon reboot it successfully reconnected the saved network and I submitted this post. :slight_smile:


#6

maybe this is because of the repeater manage blacklist the jetpack.

Can you disable repeater manager? If you use the latest firmware you will have this option.


#7

I have 3.0.0.9, which the router says is the latest. Where do I find the option to disable the repeater manager? I don’t see that.


#8

I mean latest testing firmware. You need to download and flash by yourself.


#9

Where can I get testing firmware?


#10

You can find it in here. http://download.gl-inet.com/firmware/ar750/testing/


#11

Thanks, I will check that out.

Yesterday, I confirmed the Jetpack is transmitting on 5Ghz and the 750 transmitting on 2.4Ghz. This morning I encountered another instance of the 750 dropping connection and not re-connecting, so it doesn’t appear to be caused by using the same channel for both WAN and LAN sides.


#12

Are you using the latest v3.x testing firmware? If so, it might be a bug. Because it has a blocklist machine, it will add the SSID to block list when it fails to connect it. Will fix it later.


#13

Having the same problem with the Glinet SLATE (and firmware 3.0.0.9). I’ve spent all day using LUCI to configure a client-mode bridged connection to an AP, only to discover this bug myself. Anytime the Access Point to which I connect loses power/connection, the GLINET does NOT reconnect on its own (a reboot fixes it, as does reconnecting via the admin page). This makes it almost unusable for my particular uses.


#14

Hi @John use the travelmate service, it will reconnect automatically if it looses connection to the main router

Sat Mar 9 00:32:28 2019 user.info travelmate-[1.2.0]: interface ‘trm_wwan’ on ‘radio1’ connected to uplink ‘VIKRANT84/-’ (GL-AR750S, OpenWrt 18.06.1 r7258-5eb055306f)
Sat Mar 9 03:20:29 2019 user.info travelmate-[1.2.0]: uplink ‘VIKRANT84/40:9B:CD:2F:B4:50’ is out of range (0/35), uplink disconnected (GL-AR750S, OpenWrt 18.06.1 r7258-5eb055306f)
Sat Mar 9 03:20:49 2019 user.info travelmate-[1.2.0]: interface ‘trm_wwan’ on ‘radio1’ connected to uplink ‘VIKRANT84/-’ (GL-AR750S, OpenWrt 18.06.1 r7258-5eb055306f)

You can see here that it lost connection at 03:20:29 and then it reconnected in 20 seconds


#15

Travelmate - more details here:


#16

what is “travelmate?”


#17

Are you serious? Did you not see the post immediately above?

And have a look at this: https://forum.openwrt.org/t/travelmate-support-thread/5155


#18

Got travelmate going, it seems to be working. Thank you for the help!


#19

Yes, of course I saw the preceding messages. Both refer to travel mate. Neither explained what it is.

No problem. I’ll just return this buggy piece of junk to Amazon. Thanks for your time.


#20

Hello Thunk, sorry we didn’t give more details, follow this link to a different thread AR750s Keeps disconnecting

Travelmate is a package made for open Wrt firmware, it has a set of instructions and config to help you use a router as a travel router, it will easily connect to a wifi and repeat it, it is stable and it has a special script to connect easily to captive portals on hotels wifis. Well basically travelmate should be something implemented into our small router the Slate. In fact it is, they call the script, gh health, but looks like this one isn’t working well for some of us, so we are using the wonderful capabilities of this router to load different scripts. You are not entitled to use only official releases, if you have enough knowledge, you can even write your own software and make it work exactly as you would like to.

What you need to do is simple :slight_smile:
First step is, delete this package using Puty (you will need to use some google)

killall gl_health
mv /usr/bin/gl_health /usr/bin/gl_health_bak

Then install travelmate files from Luci, to be more precise, packages.

After that, follow the instructions I sent you on the link.

There you go you have installed and set travelmate to enabled, now hopefully, you will have almost no disconnections and the router will reconnect automatically and quickly.

This router is a wonderful piece of tech, if the software was good. bugs are distroying it. hopefully, the devs are watching our frustration and they will soon release a bugfree firmware.