Ar750s-ext Broken after openwrt upgrade?

Hello to all,

so I was trying to fix this issue ar750s 3.100 openvpn failed load ovpn and seems that I got shoot on the foot now :cry:

While I was checking how I can upload the ovpn file to the luci-app-openvpn via the admin portal I notice from this thread that the user had openwrt 19.07 and maybe this was a blocker for me to see the upload ovpn option.

So I check on openwrt portal of how to upgrade my ar750s to the 19.07.1 also. So I followed the steps to do the upgrade.

cd /tmp
wget openwrt-19.07.1-ar71xx-generic-gl-ar750s-squashfs-sysupgrade.bin
sysupgrade /tmp/openwrt-19.07.1-ar71xx-generic-gl-ar750s-squashfs-sysupgrade.bin

and I got as a message

Invalid image type.
Image check ‘platform_check_image’ failed.

So by looking again on the web I notice this thread which was mention to run the command
Sidenote here; I didnt do a md5 or sha256 check to make sure the file wasn’t corrupted after the download :confused:

sysupgrade --force -n xxxxx.bin

And so I did.
I left it around 20-30 mins and when I came back I didnt see any wifi ssid open.
I checked also via ethernet to see the GUI on but nothing.

Searching on the web I read that openwrt doesn’t have the GUI luci and wifi enable so I need to connect via ssh to the router on the network with the router having the ip .1 but again nothing.

To continue with this story I then tried to connect to uboot. I followed the steps that GL.iNet have on their portal but didn’t see any response on the .1.0/24 with the router being .1. Note here that the power led was lit the 5g led started blinking slowly and after 5 flashes it turned off and the 2g led lit.

I found also this thread for how to use debrick and try to go directly to uboot menu ( but nothing. The power led is lit and the 2g led also lit.

I also read that the first branch of those ar750s had an issue with the uboot which if you wanted to fix it/bypass it you had to open the device and solder/hotwire two pins on the PCB (AR-750S Uboot recovery not working) but I dont want to arrive to this option.

Also I forgot to mention that if I let it boot normally I think that the device is actually rebooting/resetting because the connection via ethernet seems to be unstable (connect & disconnect every 2-3 sec).

So this brings us here… I don’t know what to do next… what to look for this issue…

Any ideas? Any help?

Sorry for the long thread but I believe you needed to know all the steps I took and what I did tried.

PS: I have the firewall of my laptop disabled (Windows + Eset antivirus)

Thank you!

Follow the debrick guide here:

That is where you flash “vanilla” OpenWRT btw, as well as reverting back to the GL firmware.

1 Like

@Johnex I did I can’t get the web portal to show up or 1.1/index.html or 1.1/uboot.html.
I tried also ssh to 1.1 but nothing…

I tried again and now it worked… WTH!! like why?! I have been trying the same thing 3 hours…

what do you mean with “That is where you flash “vanilla” OpenWRT btw”?
To install the new openwrt 19.07.1 on the ar750s-ext what needs to be done? I followed the page I pasted above.

I mean that Vanilla OpenWRT, aka the firmwares you download from, they are not compatible with the GL firmware uploader, and you can’t use sysupgrade either. Switching between Vanilla OpenWRT and GL firmware, you MUST upload the firmware using uBoot. On top of that, the only recommended way to update the GL firmware is using the upload ui, uBoot or the GL API, not sysupgrade.

If you want to go to 19.07.1, go to uBoot and upload that bin you found:

1 Like

Maybe your not setting your ethernet ip settings correct , you also need to turn off any other internet connections like wifi . Pretty much just press airplane mode and make sure you have ready in your browser because as soon as it blinks into uboot you want to visit instantly