AR750S-EXT Repeater can’t access gui

Hi, i have AR750S-EXt set as Repeater
My main router assigned to AR750S i can ping it but i can’t access GUI.
I have another device plugged in AR750s which i can ping and access that device GUI…

What would prevent accessing AR750s GUI?

If the GL-AR750S is in Router network mode on Admin Panel → MORE SETTINGS → Network Mode, then is the router’s default LAN IP address where you can access the GL.iNet UI from the LAN side. is the router’s WAN IP address which is blocked by the GL.iNet router’s firewall and cannot be accessed from WAN side (i,.e., main router’s side). You have to add port forwarding through the firewall to do so on Admin Panel → FIREWALL.


Router is not in router mode. It’s in Extender mode

That is strange! Are you able to log in via SSH? You may have to do a reset to factory.

BTW, I always set a Static IP in all my network devices (non-client), instead of having to get an IP from the main router’s DHCP.

So here what I did.

  • Hold power button factory default
  • Router rebooted and I got 192.168.8.x range ip for my laptop
  • Connected to AR750S-EXT set changed the Network Mode to Extender
  • It asked me to select my primary Router wifi SSID and password.
  • AR750S-Ext rebooted and connected to my main Router by wifi
  • I can ping AR750S-EXT with 192.168.1.X that my DHCP server (primary router) assigned
  • I can’t connect to GUI…
  • Tried SSH same problem
  • I can confirm I have the latest firmware on the device…

Can you try setting the router to Static IP, reboot, then switch to Extender mode?

It seems in the other thread you posted on, you have to open Port 80 for http and Port 22 for ssh through the WAN.

Hi, on my main router i set the AR750s to a static ip… and rebooted. no luck…

do i need to open port 80 and 22 from the main router?

Also any security concern to opening those ports?

Here is the explaination:

The extender mode, uses layer3 relay which caused this behavior. That is when you are connecting to AR750s you cannot access the router’s UI at 192.168.1.x.

But if you set your pc’s IP to static 192.168.8.x and you will be able to access to, in extender mode.

When you reset the router, you can just hold for 4 seconds so that it goes from extender mode to router mode without reseting everything.

Would existing connected clients be disconnected and the router has to be switched back to Extender mode afterwards?

Confused here… if i leave it in extender mode, i can’t get access to GUI without setting static ip in 192.168.8.x ?? My PC is on wifi to my main router…

That would be a hassle for sure! I would try what the OP stated in the other thread.

My understanding is:

  1. Set a Static IP for the GL-AR750S itself in the DHCP of the main router.
  2. Open Ports 80 and 22 on the GL-AR750S itself while in Router network mode, before switching to Extender, using Admin Panel → Firewall. There is no security problem because it is all on the LAN.

I switched to Router network mode, went in Firewall settings and opened port 80 for ip 192.168.1.xx which is my STATIC ip for GL-AR750S. Went back to Extender mode still can’t access the GUI…

The Port 80 TCP is to be open for all LAN IP addresses, not only for the router IP.

Maybe ask the OP in the other thread how to make it work.

Good reason why I don’t use Extender (only Router and Access Point) :rofl: :rofl:

that’s the only option I think… I have device that has only ethernet port and I am using AR750S to convert the wifi to ethernet so that device can connect but it has to be on same network 192.168.1.xx

I have done that before with TP-Link TL-WR902AC/TL-WR802N that have “client” mode. Right now, I have a TP-Link RE580D with 4 Ethernet ports connected to main router over 5GHz wifi that gives ~500bps speed … too bad that model has been discontinued.

The GL-AR750S may work in Access Point mode, but I have not tried it.

Another person wants it also:

I just verified that when setting up extender you cannot access its UI using the IP it gets from the main router (192.168.1.x). You can only set static IP on your pc to 192.168.8.x and be able to access

Maybe this is how it works.

If the router is assigning the ip addresses then all machines need to be on the same network to be able to see each other. If the router is told that its address is then all machines need to be on the range. Any other routers connecting to that router need to be on their own range and the gateway of those other routers point to All of which need to be on the SAME subnet mask

The PC being on will stop it from being able to interact on that network. Change the devices connected to the router to DHCP or put them static on the same network and the network will jump into life.

After thought… Change the gateway address on the PC to and see if that does anything while the rest remains on the settings.