AT+COPS=? not working

My T-Mobile SIM card can register on T-Mobile / Sprint / AT&T. I am trying to set the preferred operator, every time I send AT+COPS=?, I get SIM card cannot be registered. Please check: 1. You are using the compatible modem for your carrier; 2. Whether a specific APN or data plan is required. (Internet still works tho) and no AT commands work any more ERROR: Failed to execute command!

from EP06&EG06&EM06_AT_Commands_Manual_V1.0, 6.1. AT+COPS Operator Selection, this test command should return available operators. Is this a firmware issue?

GL-X750 with Firmware: 3.215 stable.

Looks like the majority of AT commands in EP06&EG06&EM06_AT_Commands_Manual_V1.0 do not work. Is there a firmware update available for EP06-A?

What is your current EP06-A firmware? Can you just send me a screenshot?

I can give you a guide to upgrade it.


I’d also be interested if there’s a firmware update to see if it fixes the issues I have with SMS messaging.

Mine shows the same modem ID as above.


Sent to both of you

@asgdfgfew23 @EddieA

1 Like

anyone had luck with AT+COPS? after upgrading the firmware AT+COPS=? still does not work (should return within 180s per AT manual).

Looks like the UI cancels the command after 120s, but the command could take longer to run?

I just tried on my Opal with an external EC25-AF and both AT+COPS? and AT+COPS=? completed in under 2 seconds in the GL modem manager when not connected.


+COPS: (2,"Visible","Visible","311480",7),,(0-4),(0-2)



+COPS: 0,0,"Visible",7


Have you tried running it from ssh/putty to bypass the timeout? I know I’ve seen it take several moments when looking on an android device. You can get the correct bus setting from the dmesg command. The command did not return information for me on the CLI, so its just a suggestion, but the EP06 may behave differently.

root@GL-SFT1200:~# dmesg | grep ttyUSB
[   29.218461] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
[   29.233569] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
[   29.248885] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
[   29.264094] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB3

gl_modem -B 1-1 -D AT /dev/ttyUSB2 COPS=?

Thanks @Bitty_Bytes

under 2 seconds in the GL modem manager when not connected.

Does it behave differently when the modem is connected to a network? That’s how I ran the AT commands (remotely)

I got the same results with socat over SSH, even with ignoreeof (not sure why sometimes I got EOF causing socat to exit), AT+COPS=? never returns the response

is there a syntax guide for gl_modem? not sure what I am doing wrong here, /dev/ttyUSB2 is the correct path

root@GL-X750:~# gl_modem -B 1-1 -D AT /dev/ttyUSB2 COPS=?
Error opening serial port  - No such file or directory(2).

Usage:<gl_modem> <command> [option]
root@GL-X750:~# ls -l /dev/ttyUSB2
crw-rw----    1 root     dialout   188,   2 Jan 18 09:06 /dev/ttyUSB2

Did dmesg | grep ttyUSB show USB 1-1.2? You’ll need to change -B to match your configuration.

Also gl_modem -B 1-1 AT /dev/ttyUSB2 ATI is the example I saw for AT commands.

It was just trial and error to see what gl_modem options were available for me. I did not find any documentation on it, just a few forum posts.

thanks, I figured out the command to use. At least this time it shows an error on network scan. I wonder if it requires the modem to be not currently connected to network

root@GL-X750:~# gl_modem -B 1-1.2 AT /dev/ttyUSB2 'AT+COPS=?' 


I just tried AT+COPS=? on my GL-X750 (also an EC25-AF) and it took a 20 seconds (initially timed-out, but completed the 2nd time) while connected and completed immediately when not connected from the GL GUI modem manager.

gl_modem -B 1-1.3

Usage:<gl_modem> [-D] [-B <bus>] <command> [option]

Command possible:connect|connect-auto|new-connect-auto|disconnect|sim-status|AT|signal|cells|thermal|wifi_lte_interference

Edit: The AT+COPS=? does complete from the CLI. And my mistake, -D should be before -B to display the extra info.

gl_modem -B 1-1.3 AT /dev/ttyUSB2 AT+COPS=?

+COPS: (2,"Visible","Visible","311480",7),,(0-4),(0-2)


gl_modem -D -B 1-1.3 AT /dev/ttyUSB2 ATI
vid 2C7C,pid 125

Revision: EC25AFFAR07A08M4G

1 Like