B1300 firmware update


#1

Hello,

I read in forum that you are working on new firmware v3 on the B1300 any news about it and release date please?

I am using this small router and it is really nice expect the software really outdated sadly =(


#2

Our target is to release the beta version by end of Jan 2019


B1300 ddns
#3

Thanks for the information, looking forward to the update.


#4

Thanks for the information. Will v3 finally make the internal switch handle VLAN correctly? I bought this device about a year ago and was not able to use it because it does not handle VLAN interfaces correctly :confused:


#5

Cannot handle VLAN? Could you please explain more about what’s your usage scenario?


#6

There are actually at least two posts about the VLAN problem on this forum (search “b1300”). In short: I need to trunk two VLANs (100 and 110) to a single physical port and bridge the two VLAN interfaces to one WIFI ESSID each, so traffic from each ESSID goes only to the attached VLAN and leaves the device via the trunk port. I cannot use two physical ports (only one cable) but don’t need the other two physical ports.

There is a device from ASUS using the same internal switch setup which seems to have the same problem (search OpenWRT forum) as well as a two years old patch for the driver which however never made it upstream.

UPDATE: After trying again I think I managed to set up working VLANs.


#7

Looking forward to the update too. :grin:


#8

@User_Felix @micmon @Ben Testing firmware for B1300 is available, you can have a try. http://download.gl-inet.com/firmware/b1300/testing/


#9

The mesh button doesn’t work (no change to the mesh LED), so mesh networking doesn’t work.


#10

Yup, we are optimizing mesh network now. The v3.0 testing firmware doesn’t integrated into mesh network yet.


#11

Works fine for me (not using Mesh stuff). I was hoping to see the base OpenWRT updated to 18.x but sadly it is still 15.x


#12

What? The new firmware still sticks to 15.x ? :sob:


#13

If you want to use OpenWrt 1806 then you have to use open source wifi drivers. Although these open source wifi drivers works fine, the performance does not beat Qualcomm drivers.

Qualcomm driver only works on their SDK which is based on 15.x. The good news is that now the kernel is 4.4.60.


#14

Well that is unfortunate but at least I can report that the test build runs stable so far and WiFi performance seems to be excellent.


#15

congratulation finished before spring festival


#16

@alzhao I have upgraded to this testing firmware, but the DNS over TLS doesn’t work, could you confirm this ? Thx.


#17

I upgraded with don’t keep settings checked, working for me.


#18

As an observation, there’s more going on with that OLD version of OpenWRT than just an old kernel. There’s things like it not working with modern USB 4G and soon to be out 5G modems, because they don’t function as a classic 3G, they’re a USB CDC-ECM device, which for the source branch you’re building out of , it just simply doesn’t work (The Black micro-bricks work just fine…but they’re using the latest LEDE derived OpenWRT…),

There’s more. It’s enough to be infuriated and deeply disappointed with GL-Inet, to be honest with you. It’s something you should’ve contemplated DEEPLY before designing the device in the FIRST place.

Someone needs to resolve this situation or offer an option for a build using the same, knowing peak performance may not be obtained. What is the performance degradation between the two classes of drivers and has anyone even looked to see if it’s an “old” issue and they’ve fixed it?


#19

Your frustration should be with Qualcomm, not GL-Inet, GLinet simply take Qualcomm’s SDK and modify it with their apps/branding. The underlying core components are all provided by the QSDK, its true that its based on openwrt, but its not as simple as adding a couple of packages etc and typing make -j4.

Its qualcomm that should update their SDK to use a more recent openwrt version, in fact, they should ideally submit code directly to openwrt and not fork it… but since they rely on closed-source hardware acceleration and their code would never get accepted into linux, they fork and do major modifications then send those tarballs to customers like GL-inet. I guess a less ideal option would be qualcomm compiling their closed source Wifi drivers against current kernels so people using mainline openwrt can leverage the higher performance, but again their modifications affect many core parts of the network stack, its not like you can uninstall ath10k and install qsdk-wlan-driver and everything works, not that simple unfortunately.

I used to be frustrated too, but its not the vendors, its the chipset developer that is to blame (this is the same case with Asus, tplink…etc, they all use sdks provided by chipset makers).

Having said all of that, you can use mainline openwrt and with some tricks (irqbalance, assigning cores), you can reach pretty respectable performance numbers with the open source drivers.


#20

Perhaps you could share some insight.
I have the b1300 with latest test firmware installed.
Copying known working Wireguard and OpenVPN client configs results in the same error “no internet connection” when I press connect under the selected VPN client config.

I am of course connected to the internet when i’m attempting to connect to my VPNs.