Beryl AX (MT3000) firmware issues

Hi there, I would like to post here a couple of issues that I’m experiencing as some others might have them or might have found a solution.

  1. With clean gl inet firmware 4.1.2 and 4.1.3, switching WAN to LAN usage and then going to LuCi interfaces, produces the following message:

    Pressing Continue breaks something as the LANs do not work any longer.

  2. When using the modem Quectel EM06-E with a USB interface, it cannot connect at all with any of the offered protocols although the operator is recognized as well as the signal quality report and AT commands work fine. The same works fine with the older model Beryl (MT1300) using 3g/LTE with gl inet firmware 3.215 and with ModemManager using vanilla openwrt 22.

A1 Do you have hardware acceleration enabled?
There was a issue with it breaking stuff.
A2. You could try a different firmware like the latest snapeshot. I would not keep settings and instead load a config file in LuCI.

Quectel EM06-E is it a M.2 in a USB enclosure. It might not be getting enough power. Could also be a driver issue.

I am using the latest snapshot for the Beryl AX

:gl_emoji_dizzy:I do not work for and I am not directly associated with GL.iNet :gl_emoji_shacking:

You may take a look at my experience using eg25-g with mt3000

I THINK they cater the mt3000 to newer 5g modems than legacy LTE modems, but driver update and some configuration file editing should work, that requires developers assistance

1 Like

It makes no difference whether it is enabled or not in 4.1.3 nor 4.2.0. At least for the LuCI interfaces issue.

I tried the beta and snapshot too. Ofc I did skip keeping settings for all these tests as I’m still testing the device.
But also with 4.2.0 beta, I had further issues as the modem settings were not applied/saved correctly. At least the device path was being truncated to /dev/ instead of keeping /dev/ttyUSBX or /dev/cdc-wdm)

That’s right. I learnt that already with Beryl MT1300 as the included power brick wasn’t giving enough power, so I’ve been using a more powerful one that meets the required Watts for this Quectel and Beryl AX. Like I said, same setup works fine in Beryl MT1300 that has the same power input as the Beryl AX MT3000. But my Beryl MT1300 does have vanilla openwrt 22.

It could be although I believe it is more a software issue (ModemManager and related) since the driver for EP06 (what GL inet use themselves) is the same for the EM06. I really hope they start using openwrt 22 instead 21 for the snapshot/betas soon…

So currently your modem stays alive for just 2 hours? Have you tried with a more powerful power brick? With the one they provided mine was dying eveytime I made a speedtest (intensive usage)

Probably, but they use very similar LTE modems in at least the routers Spitz and Cirrus, EC25 and EP06, so to get them working shouldn’t be a big challenge. Or do these modem have other modules/software packages not included with non-LTE routers? Hopefully someone from GL-inet can shed some light on this.

The 2 hour shutdown problem is already fixed by the developers

Tested again yesterday, stays online whole night (mt3000 4.2 beta 4 20230222)

i had to do this file editing everytime i upgrade the firmware Gl-mt3000 v4.1.2 beta : quectel eg25-g with external USB enclosure - #13 by lincoln

I currently have the same 4.2.0 beta4 firmware downloaded today (openwrt-mt3000-4.2.0-0223-1677143187)
My modem EM06 firmware is btw the following:

root@OpenWrt:~# socat - /dev/ttyUSB2,crnl



I will try to check how to upgrade it just in case but I believe it is the latest version.

Ah, almost forgot about the third issue with at least firmware 4.1.3 latest stable release:
3. When using WiFi Scheduled Tasks to turn on and off the WiFis, it would not use the custom settings but would create open WiFis (no Security at all, i.e. WPA, etc) and they would be called MTK_CHEETAH_AP_2.4G and MTK_CHEETAH_AP_5G for the respective frecuencies.

  1. WiFi Scheduled Tasks issue is now resolved in 4.2.0 but 1. and 2. are still the same. Probably 2. EM06-E support won’t work properly until openwrt 22 instead of 21 is used in the gl inet firmware… pity we can’t try latest openwrt vanilla in this router just yet.